summaryrefslogtreecommitdiff
path: root/sys-libs/libsemanage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /sys-libs/libsemanage
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'sys-libs/libsemanage')
-rw-r--r--sys-libs/libsemanage/Manifest2
-rw-r--r--sys-libs/libsemanage/libsemanage-3.3.ebuild127
2 files changed, 129 insertions, 0 deletions
diff --git a/sys-libs/libsemanage/Manifest b/sys-libs/libsemanage/Manifest
index 058a6d8c9182..ae4df810d344 100644
--- a/sys-libs/libsemanage/Manifest
+++ b/sys-libs/libsemanage/Manifest
@@ -1,6 +1,8 @@
DIST libsemanage-3.1.tar.gz 179601 BLAKE2B 69450a4eda1f3728d339f65db1eec9940995fcea5208d17dca531ebc998aefbfec48fe91beffa3490e1502953aa550405fb696635d01b0eb8050c8f00f11106a SHA512 8609ca7d13b5c603677740f2b14558fea3922624af182d20d618237ba11fcf2559fab82fc68d1efa6ff118f064d426f005138521652c761de92cd66150102197
DIST libsemanage-3.2.tar.gz 178839 BLAKE2B c0925812d784923a7a239ba919fc0a0e1d84cb528cbf4a357fb7938d3c06ebd2f0b60cd3eba40b76bf7c2922a081b99b16b32dc16638aa1bfce32553e241fb9f SHA512 6ad670bb298b1bab506217b12a3fda5d2209f4387a11410f0c1b65f765ffb579b0d70795dee19048909e0b72ef904fc318be60d5a01f80ab12742ce07647a084
+DIST libsemanage-3.3.tar.gz 178890 BLAKE2B f1ff2d25f0c98e9794cb443365e6193db80a42104b645ef4edf783db2eb3d940d1f39cddfa59f9a86ba16957c77852159b3ced83c5d01ecb1811aa6255f8be83 SHA512 6026d9773c0886436ad801bc0c8beac888b6fb62034edeb863192dea4b6ef34a88e080758820fe635a20e048ac666beee505a0f946258f18571709cca5228aad
EBUILD libsemanage-3.1-r1.ebuild 4274 BLAKE2B eb0866da968e01b89d6ba51cdcdd89f8796b0beeac515a3dbb47a823d7d5b24b64e01a05948373e6a2159b80866394d98edef9d3048436e527b38f0e8a5cb40c SHA512 21cc2d83b6efd83a691010699104d7a5344c84665cc505d4cae13a1a5891c836c728760766ae9492bb1ab0ee03e4d9e764acf6d39aa52824a6e0175db72cfebf
EBUILD libsemanage-3.2.ebuild 4280 BLAKE2B 073fa436221091ee5a8594a1194c96aae7d3c73c29b34bcf0f594e6cefd3cca082599338c29c10929b11d01151c786d6c9d1d17740484a7282bf78ced31cdff6 SHA512 12d968aacde29854b50fab62d72f08219dbbac21268919cdd867ed01b36e4d8cfbd95ae496477bb4c5ab8a8479c8dbbfaa33d97d8b1856b2265df193ad22c445
+EBUILD libsemanage-3.3.ebuild 4282 BLAKE2B 3716d5e4f40f02f3c4fb51cbb9975046c8bf39906b8ec9e051d01cc9dd82c02d66abff58474472b66a9c31ee78afa43e09d6ef1aae526bf9380a8ee9512bc76a SHA512 5e131b3fe80ca66e1dd2c1de7383dfeab9172fd64eca70960373a582a12be2498d1423803144699cf1dca36c78aa2798199a255ba44b0d57a35e0e1b457b60b4
EBUILD libsemanage-9999.ebuild 4275 BLAKE2B f1cb24ab333c9f3d565d7a3d5a4fb80b6339b84b17cc4c7fc445ab1748f443d8ae15c51ff52500e8404f2e635082d24f220afa023f0516214dc2802290518efc SHA512 d2c375e0bd73b51cc663550ecad5401e2a21951105cec6fe0d12ee18e70334a0284afd3ab9eb7454dfe7a172a974804bacc86bd3071c67c03681536e8dc2eeeb
MISC metadata.xml 335 BLAKE2B 72e72bc2d0ca05bf3caafd68121e0d4616306368f355541c2944254262a3ac96a3a6b8e5503ad691c2b7bc18dc6856101c81c47de3a623efc34b23185d9d4e60 SHA512 43cef46780c81459cc75b2a09181e84698a11e81196fea4e962b8081e712de437c8af032349aeb4f1ebe84ccef9cab4978467304d05801317db7a71521cf0664
diff --git a/sys-libs/libsemanage/libsemanage-3.3.ebuild b/sys-libs/libsemanage/libsemanage-3.3.ebuild
new file mode 100644
index 000000000000..88db66d921c2
--- /dev/null
+++ b/sys-libs/libsemanage/libsemanage-3.3.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-r1 toolchain-funcs multilib-minimal
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux kernel and policy management library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/2"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=sys-libs/libsepol-${PV}:=[${MULTILIB_USEDEP}]
+ >=sys-libs/libselinux-${PV}:=[${MULTILIB_USEDEP}]
+ >=sys-process/audit-2.2.2[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-lang/swig-2.0.4-r1
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+
+ echo >> "${S}/src/semanage.conf"
+ echo "# Set this to true to save the linked policy." >> "${S}/src/semanage.conf"
+ echo "# This is normally only useful for analysis" >> "${S}/src/semanage.conf"
+ echo "# or debugging of policy." >> "${S}/src/semanage.conf"
+ echo "save-linked=false" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Set this to 0 to disable assertion checking." >> "${S}/src/semanage.conf"
+ echo "# This should speed up building the kernel policy" >> "${S}/src/semanage.conf"
+ echo "# from policy modules, but may leave you open to" >> "${S}/src/semanage.conf"
+ echo "# dangerous rules which assertion checking" >> "${S}/src/semanage.conf"
+ echo "# would catch." >> "${S}/src/semanage.conf"
+ echo "expand-check=1" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Modules in the module store can be compressed" >> "${S}/src/semanage.conf"
+ echo "# with bzip2. Set this to the bzip2 blocksize" >> "${S}/src/semanage.conf"
+ echo "# 1-9 when compressing. The higher the number," >> "${S}/src/semanage.conf"
+ echo "# the more memory is traded off for disk space." >> "${S}/src/semanage.conf"
+ echo "# Set to 0 to disable bzip2 compression." >> "${S}/src/semanage.conf"
+ echo "bzip-blocksize=0" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Reduce memory usage for bzip2 compression and" >> "${S}/src/semanage.conf"
+ echo "# decompression of modules in the module store." >> "${S}/src/semanage.conf"
+ echo "bzip-small=true" >> "${S}/src/semanage.conf"
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ local -x CFLAGS="${CFLAGS} -fno-semantic-interposition"
+
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ all
+
+ if multilib_is_native_abi; then
+ building_py() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ "$@"
+ }
+ python_foreach_impl building_py swigify
+ python_foreach_impl building_py pywrap
+ fi
+}
+
+multilib_src_install() {
+ emake \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${ED}" install
+
+ if multilib_is_native_abi; then
+ installation_py() {
+ emake DESTDIR="${ED}" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ install-pywrap
+ python_optimize # bug 531638
+ }
+ python_foreach_impl installation_py
+ fi
+}
+
+multiib_src_install_all() {
+ python_setup
+ python_fix_shebang "${ED}"/usr/libexec/selinux/semanage_migrate_store
+}
+
+pkg_postinst() {
+ # Migrate the SELinux semanage configuration store if not done already
+ local selinuxtype=$(awk -F'=' '/SELINUXTYPE=/ {print $2}' "${EROOT}"/etc/selinux/config 2>/dev/null)
+ if [ -n "${selinuxtype}" ] && [ ! -d "${EROOT}"/var/lib/selinux/${selinuxtype}/active ] ; then
+ ewarn "Since the 2.4 SELinux userspace, the policy module store is moved"
+ ewarn "from /etc/selinux to /var/lib/selinux. The migration will be run now."
+ ewarn "If there are any issues, it can be done manually by running:"
+ ewarn "/usr/libexec/selinux/semanage_migrate_store"
+ ewarn "For more information, please see"
+ ewarn "- https://github.com/SELinuxProject/selinux/wiki/Policy-Store-Migration"
+ fi
+}