summaryrefslogtreecommitdiff
path: root/sys-libs/libnvme/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-06 05:42:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-06 05:42:43 +0000
commit9e0addc1cf71ebec277b59e38eb3fa30e650cf9f (patch)
treefad7eaf86ed6caf32c2c6e1b52157364ec9a79f6 /sys-libs/libnvme/files
parentd82c6c919aa63b46ec1683492b75162951f09072 (diff)
gentoo auto-resync : 06:02:2024 - 05:42:43
Diffstat (limited to 'sys-libs/libnvme/files')
-rw-r--r--sys-libs/libnvme/files/libnvme-1.6-lld-17.patch26
-rw-r--r--sys-libs/libnvme/files/libnvme-1.6-musl.patch90
2 files changed, 0 insertions, 116 deletions
diff --git a/sys-libs/libnvme/files/libnvme-1.6-lld-17.patch b/sys-libs/libnvme/files/libnvme-1.6-lld-17.patch
deleted file mode 100644
index c64b4a80cbfb..000000000000
--- a/sys-libs/libnvme/files/libnvme-1.6-lld-17.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-https://github.com/linux-nvme/libnvme/pull/725
-
-From a5cc9074765bf400336f78a05c8374b9788ad670 Mon Sep 17 00:00:00 2001
-From: Alfred Wingate <parona@protonmail.com>
-Date: Tue, 10 Oct 2023 04:22:48 +0300
-Subject: [PATCH] build: remove symbol which doesn't exist in libnvme-mi.so
-
-* Added in bb70b874dac13a15c37ce1dd1de866d6a5dd428d, but was never used.
-
-Signed-off-by: Alfred Wingate <parona@protonmail.com>
----
- src/libnvme-mi.map | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/src/libnvme-mi.map b/src/libnvme-mi.map
-index f1ce7125..41e81106 100644
---- a/src/libnvme-mi.map
-+++ b/src/libnvme-mi.map
-@@ -49,7 +49,6 @@ LIBNVME_MI_1_1 {
- nvme_mi_admin_security_send;
- nvme_mi_admin_security_recv;
- nvme_mi_endpoint_desc;
-- nvme_mi_root_close;
- nvme_mi_first_endpoint;
- nvme_mi_next_endpoint;
- nvme_mi_first_ctrl;
diff --git a/sys-libs/libnvme/files/libnvme-1.6-musl.patch b/sys-libs/libnvme/files/libnvme-1.6-musl.patch
deleted file mode 100644
index bc1037820311..000000000000
--- a/sys-libs/libnvme/files/libnvme-1.6-musl.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-https://github.com/linux-nvme/libnvme/pull/724
-
-From f78a97acf9cdec1031d81f0e8a3956fc8f28c33c Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Sat, 30 Sep 2023 06:38:53 +0100
-Subject: [PATCH 1/2] test: handle POSIX ioctl prototype
-
-glibc has the following prototype for ioctl: int ioctl(int fd, unsigned long request, ...)
-POSIX (inc. musl) has the following for ioctl: int ioctl(int fd, int request, ...)
-
-Check which prototype is used in <sys/ioctl.h> to avoid a conflict and conditionally
-define the right one for the system.
-
-Bug: https://bugs.gentoo.org/914921
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/meson.build
-+++ b/meson.build
-@@ -230,6 +230,16 @@ conf.set(
- ),
- description: 'Is network address and service translation available'
- )
-+conf.set(
-+ 'HAVE_GLIBC_IOCTL',
-+ cc.compiles(
-+ '''#include <sys/ioctl.h>
-+ int ioctl(int fd, unsigned long request, ...);
-+ ''',
-+ name: 'ioctl has glibc-style prototype'
-+ ),
-+ description: 'Is ioctl the glibc interface (rather than POSIX)'
-+)
-
- if cc.has_function_attribute('fallthrough')
- conf.set('fallthrough', '__attribute__((__fallthrough__))')
---- a/test/ioctl/mock.c
-+++ b/test/ioctl/mock.c
-@@ -114,7 +114,11 @@ void end_mock_cmds(void)
- } \
- })
-
-+#ifdef HAVE_GLIBC_IOCTL
- int ioctl(int fd, unsigned long request, ...)
-+#else
-+int ioctl(int fd, int request, ...)
-+#endif
- {
- struct mock_cmds *mock_cmds;
- bool result64;
-@@ -141,7 +145,7 @@ int ioctl(int fd, unsigned long request, ...)
- result64 = true;
- break;
- default:
-- fail("unexpected %s %lu", __func__, request);
-+ fail("unexpected %s %lu", __func__, (unsigned long) request);
- }
- check(mock_cmds->remaining_cmds,
- "unexpected %s command", mock_cmds->name);
-
-From 149c006d23da60e168485ede722730dc2b725e6b Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Sat, 30 Sep 2023 06:43:39 +0100
-Subject: [PATCH 2/2] meson: make building tests conditional
-
-Just like we do for docs.
-
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/meson.build
-+++ b/meson.build
-@@ -273,7 +273,9 @@ subdir('internal')
- subdir('ccan')
- subdir('src')
- subdir('libnvme')
--subdir('test')
-+if get_option('tests')
-+ subdir('test')
-+endif
- subdir('examples')
- subdir('doc')
-
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -6,6 +6,7 @@ option('rstdir', type : 'string', value : '', description : 'directory for ReST
-
- option('docs', type : 'combo', choices : ['false', 'html', 'man', 'rst', 'all'], description : 'install documentation')
- option('docs-build', type : 'boolean', value : false, description : 'build documentation')
-+option('tests', type : 'boolean', value : true, description : 'build tests')
-
- option('python', type : 'feature', value: 'auto', description : 'Generate libnvme python bindings')
- option('openssl', type : 'feature', value: 'auto', description : 'OpenSSL support')
-