summaryrefslogtreecommitdiff
path: root/sys-libs/libcxx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
commit0c764edfecb7e9e124d4669acd98bed09e23b6c0 (patch)
tree2862ab17d2f88cb7c9614b7fbe579f25ae604b8d /sys-libs/libcxx
parentae1bf373db295b495e1f685d116e3411bf10df0b (diff)
gentoo auto-resync : 01:08:2022 - 03:14:32
Diffstat (limited to 'sys-libs/libcxx')
-rw-r--r--sys-libs/libcxx/Manifest2
-rw-r--r--sys-libs/libcxx/libcxx-15.0.0.9999.ebuild46
2 files changed, 11 insertions, 37 deletions
diff --git a/sys-libs/libcxx/Manifest b/sys-libs/libcxx/Manifest
index b439798a1f4b..87d9c0e0ae8a 100644
--- a/sys-libs/libcxx/Manifest
+++ b/sys-libs/libcxx/Manifest
@@ -9,5 +9,5 @@ DIST llvmorg-14.0.4.tar.gz 158088617 BLAKE2B 7fb894548dce72593a8639b4d0220d24995
EBUILD libcxx-13.0.1.ebuild 6780 BLAKE2B 575c9089d74bddc871e97147c53f7c298cd1683b989eba6b50601b45693c11d0647e3bd6f70c0a75caaea7ee3fea2f88f1bbad444d7f1785a62175337659e2e3 SHA512 f0ff78e48acca25cb925aee5106fba0d547ab8522ccfd65e2198d4f481f83abbadc415ac3808e45387fc945980f9892fdbda3b6a26d54163cebfa4f12fa17172
EBUILD libcxx-14.0.4.ebuild 6958 BLAKE2B e756b18011f0097115d4bc692fc4eb84c84d0ac68694b4611e4f73a032cb3b04e1137f7089b7b7dc4d0b37d1463465a791e468110c3c61438728eb90e7b9425f SHA512 fc0bde903c11f74f78f1d432bb0f5c15d002fd8c390719c6e4b9d77f1459c0397346b97c3cc51d75b34a486adb9b7992e646e5d043b3f278e46560d56e9d43cd
EBUILD libcxx-14.0.6.ebuild 6961 BLAKE2B 9f04467faee5cd162906a77764b3ee4af20f3f7b7821c00a078293c922912111f88ba479bbc9effc363284bfafcac71ec9a42db26ea73c8469670408b3de0d96 SHA512 40fdd13646e02c3fb2cd54dab00a5ff41e7b8fa523d197119aac5e19d0540b35cf5d5bbc770d2511179807883af122f764e2da9918e685ae5b811930dfeb47ad
-EBUILD libcxx-15.0.0.9999.ebuild 7161 BLAKE2B 003e9af70722b09e98efb51ead68533dff908a6f36ea6b9d73faa8be1e64c5e2d14c229bd3fefd4b56910ab4fd2d2cd7e068a60f1f6ffebca55ac7cfff47f83f SHA512 fae292ba51bbee7c2df22d58ce377161fdbaa5150e2f46197e2763741e858a80f3cdce13fa1ed22d0ff6aff276bc8217d1bc785f4ab30832abffbb438038689f
+EBUILD libcxx-15.0.0.9999.ebuild 6065 BLAKE2B 3816a2235860d89f5afcfaeaccc1d84a115ad0a06526f3b4383247e165cc1917737fa5c9c66d1189871ed60371c50db93d8194daaaa8c2b708d8dc0ec810c571 SHA512 22e742b874b9403f64eee8eee76552cd145ed4eca65523bd47b2bdddbb2a9436982c010bc10980ada9bb4a63a5d8663eec2d124a3517355eccbdd22b32f85bfb
MISC metadata.xml 828 BLAKE2B 40af456df8ac1cfdb66fd62a217abbb4ca837956529906118c35232000435d9e991d18dd0332b7b95eed70d4c7610c7a1aee80af8ba511763edc1423749a4aa4 SHA512 257f8fd05fcade26ca02305356b67c8e2d67a87b180e38a189a659212093b07b9a710b871fbaab894dba9eba5fe450b76c52cc82f6405c24cc1ab2df3abe8bfd
diff --git a/sys-libs/libcxx/libcxx-15.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-15.0.0.9999.ebuild
index 3acf567e062b..d95f996ca33b 100644
--- a/sys-libs/libcxx/libcxx-15.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-15.0.0.9999.ebuild
@@ -14,16 +14,13 @@ HOMEPAGE="https://libcxx.llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
KEYWORDS=""
-IUSE="+clang +libcxxabi +libunwind static-libs test"
-REQUIRED_USE="
- libunwind? ( libcxxabi )
- test? ( clang )
-"
+IUSE="+clang +libcxxabi static-libs test"
+REQUIRED_USE="test? ( clang )"
RESTRICT="!test? ( test )"
RDEPEND="
libcxxabi? (
- ~sys-libs/libcxxabi-${PV}[libunwind=,static-libs?,${MULTILIB_USEDEP}]
+ ~sys-libs/libcxxabi-${PV}[static-libs?,${MULTILIB_USEDEP}]
)
!libcxxabi? ( >=sys-devel/gcc-4.7:=[cxx] )
"
@@ -104,32 +101,14 @@ multilib_src_configure() {
strip-unsupported-flags
fi
- # we want -lgcc_s for unwinder, and for compiler runtime when using
- # gcc, clang with gcc runtime (or any unknown compiler)
- local extra_libs=() want_gcc_s=ON want_compiler_rt=OFF
- if use libunwind; then
- # work-around missing -lunwind upstream
- extra_libs+=( -lunwind )
- # if we're using libunwind and clang with compiler-rt, we want
- # to link to compiler-rt instead of -lgcc_s
- if tc-is-clang; then
- local compiler_rt=$($(tc-getCC) ${CFLAGS} ${CPPFLAGS} \
- ${LDFLAGS} -print-libgcc-file-name)
- if [[ ${compiler_rt} == *libclang_rt* ]]; then
- want_gcc_s=OFF
- want_compiler_rt=ON
- extra_libs+=( "${compiler_rt}" )
- fi
+ # link against compiler-rt instead of libgcc if this is what clang does
+ local want_compiler_rt=OFF
+ if tc-is-clang; then
+ local compiler_rt=$($(tc-getCC) ${CFLAGS} ${CPPFLAGS} \
+ ${LDFLAGS} -print-libgcc-file-name)
+ if [[ ${compiler_rt} == *libclang_rt* ]]; then
+ want_compiler_rt=ON
fi
- elif [[ ${CHOST} == *-darwin* ]] && tc-is-clang; then
- # clang-based darwin prefix disables libunwind useflag during
- # bootstrap, because libunwind is not in the prefix yet.
- # override the default, though, because clang based libcxx
- # should never use gcc_s on Darwin.
- want_gcc_s=OFF
- # compiler_rt is not available in EPREFIX during bootstrap,
- # so we cannot link to it yet anyway, so keep the defaults
- # of want_compiler_rt=OFF and extra_libs=()
fi
# bootstrap: cmake is unhappy if compiler can't link to stdlib
@@ -156,12 +135,9 @@ multilib_src_configure() {
# we're using our own mechanism for generating linker scripts
-DLIBCXX_ENABLE_ABI_LINKER_SCRIPT=OFF
-DLIBCXX_HAS_MUSL_LIBC=$(usex elibc_musl)
- -DLIBCXX_HAS_GCC_S_LIB=${want_gcc_s}
-DLIBCXX_INCLUDE_BENCHMARKS=OFF
-DLIBCXX_INCLUDE_TESTS=$(usex test)
-DLIBCXX_USE_COMPILER_RT=${want_compiler_rt}
- -DLIBCXX_HAS_ATOMIC_LIB=${want_gcc_s}
- -DCMAKE_SHARED_LINKER_FLAGS="${extra_libs[*]} ${LDFLAGS}"
)
if use test; then
@@ -223,7 +199,6 @@ gen_static_ldscript() {
local deps=(
libc++_static.a
$(usex libcxxabi libc++abi.a libsupc++.a)
- $(usex libunwind libunwind.a libgcc_eh.a)
)
# On Linux/glibc it does not link without libpthread or libdl. It is
# fine on FreeBSD.
@@ -239,7 +214,6 @@ gen_shared_ldscript() {
libc++_shared.so
# libsupc++ doesn't have a shared version
$(usex libcxxabi libc++abi.so libsupc++.a)
- $(usex libunwind libunwind.so libgcc_s.so)
)
gen_ldscript "${deps[*]}" > lib/libc++.so || die