summaryrefslogtreecommitdiff
path: root/sys-libs/libblockdev
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-16 17:15:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-16 17:15:17 +0100
commit6e356edde093fb3589ab7a5859685e85c2873ab0 (patch)
tree5f17cc7bfbddda45678967fdc0a5f9f35fa9c02a /sys-libs/libblockdev
parentacb0389058b8ef612d851b1ab54fa37376c4b7f7 (diff)
gentoo auto-resync : 16:09:2022 - 17:15:17
Diffstat (limited to 'sys-libs/libblockdev')
-rw-r--r--sys-libs/libblockdev/Manifest4
-rw-r--r--sys-libs/libblockdev/libblockdev-2.28.ebuild125
-rw-r--r--sys-libs/libblockdev/libblockdev-9999.ebuild5
3 files changed, 129 insertions, 5 deletions
diff --git a/sys-libs/libblockdev/Manifest b/sys-libs/libblockdev/Manifest
index 1397ab616a70..66e474075901 100644
--- a/sys-libs/libblockdev/Manifest
+++ b/sys-libs/libblockdev/Manifest
@@ -1,4 +1,6 @@
DIST libblockdev-2.27.tar.gz 914021 BLAKE2B 1e02a364ac918cc9bb288d3b8745cb09378317c4b509224326d13ff8b6481ba3d44502f248680801316a9a94d7d5eac353c5659eca55a681c88511da5dfc83da SHA512 fa9faf3efefc1c76165c9456936175b2addb336a5257c43c1e41403db200386fd660203ef17559529f57b2f57b9ef768686ecd31493c58527434297c31712c10
+DIST libblockdev-2.28.tar.gz 925698 BLAKE2B 63ac7ab5bd02c1ef1848d0b252e09fe721cfe86258f063b7bab616766cbc56311707dcb2dd3a1fadf0e0840187f121aa178fd5959500cd590b846238a9d3e36e SHA512 9e01c41db4f728c8e81e710c6bb4725bbe34b3a7de25ff7f57b7b88ca6b7b5debbe858947585d314770036b2c3c533f9f8ff3d038b7ca50eee3d18f9fbe0d392
EBUILD libblockdev-2.27.ebuild 2887 BLAKE2B f44f7df71ed68e5bdbc224112164874a1a5429ac690a40aadb43612731bc6a0a31636b05ff8972e6c97f53b395ea7f7bf3bca2650aca0fcc5f9092485fc4cc99 SHA512 4c8d4c3eb67e6f622ab1aa62e3bbc2d49a8f29513fe93f3c975f44bc2d7aeaeb7a6cb1be4c54f9824b439894ec9d4fbaa2073d650ff8d3753312444583251055
-EBUILD libblockdev-9999.ebuild 2878 BLAKE2B 1ca3949ee417424809ea318ab1da22becd0b17cc3cbee9e4037e148adddae90852f49285159cd7ae4b7d9654c69bc395856fbd49499bc87d827baf2603dc8011 SHA512 7cb18160d77d20fd8c16d2ac6ea87453b3b52cffaea85ebbcda65996b06c313fb60394e37b5adb5beecc867f1a49e13bea86e270fca5a6d01b1c8e66d52af0f7
+EBUILD libblockdev-2.28.ebuild 2749 BLAKE2B cbfd7bc2e215cf435f4ca692c6f743346b43f6ff996645baf77df055bd81403c8a34224b1a444b4a3e1b55eba2f8c5dd85d2f4758cd1d13ca51a7a9bad36b63d SHA512 72d44fbafae4a9ed41d7ea7d9a873a5187b66aae2055775451807f75db888282b8de67e2e112a1930c10f3ab993f9575429b140972bfb1f62244cf3f497bdd84
+EBUILD libblockdev-9999.ebuild 2733 BLAKE2B 781c8f9580bc041dc85ac0638306ab1062d93a1fac39a120ff0bae3daa0f66b394974384bca24ec4cbf96ac40bab003b7496e7fa88686e6769b1bd85133610ea SHA512 4edff2ab09e0871e61818da2d255c2cec1b8fd2dd4341d4131074d2de55898ef1022f4f37c0806e95291d1604b1de2d9c81ad0032467b5a4470a1abba70b4625
MISC metadata.xml 1233 BLAKE2B 68512209e8f458b5b52a9d82eb86c1c831837681b2976d5050c578c3b3fdb032640c4cc99da9621aae7c061ae8332825ea5010a8f1138fbbbc34e92fccbeddeb SHA512 eb47faef934a8eafe1beeea6f901ddd6b0e7202823f57b3848f6ef131b2a5ffc968740d980a68163696d3de34a98ebef8561e63d26ffe213a42e1022577a9270
diff --git a/sys-libs/libblockdev/libblockdev-2.28.ebuild b/sys-libs/libblockdev/libblockdev-2.28.ebuild
new file mode 100644
index 000000000000..2b55a770d002
--- /dev/null
+++ b/sys-libs/libblockdev/libblockdev-2.28.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit autotools python-single-r1 xdg-utils
+
+DESCRIPTION="A library for manipulating block devices"
+HOMEPAGE="https://github.com/storaged-project/libblockdev"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/storaged-project/libblockdev.git"
+ BDEPEND="
+ sys-devel/autoconf-archive
+ "
+else
+ MY_PV="${PV}-1"
+ SRC_URI="https://github.com/storaged-project/${PN}/releases/download/${MY_PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE="bcache +cryptsetup device-mapper dmraid escrow gtk-doc introspection lvm kbd test +tools vdo"
+# Tests require root. In a future release, we may be able to run a smaller
+# subset with new run_tests.py arguments.
+RESTRICT="!test? ( test ) test"
+
+RDEPEND="
+ >=dev-libs/glib-2.42.2
+ dev-libs/libbytesize
+ >=sys-apps/kmod-19
+ >=sys-apps/util-linux-2.27
+ >=sys-block/parted-3.1
+ cryptsetup? (
+ escrow? (
+ >=dev-libs/nss-3.18.0
+ dev-libs/volume_key
+ )
+ >=sys-fs/cryptsetup-1.6.7:=
+ )
+ device-mapper? ( sys-fs/lvm2 )
+ dmraid? (
+ sys-fs/dmraid
+ sys-fs/lvm2
+ )
+ lvm? (
+ sys-fs/lvm2
+ virtual/udev
+ )
+ vdo? ( dev-libs/libyaml )
+ ${PYTHON_DEPS}
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND+="
+ dev-util/gtk-doc-am
+ gtk-doc? ( dev-util/gtk-doc )
+ introspection? ( >=dev-libs/gobject-introspection-1.3.0 )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ escrow? ( cryptsetup )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ xdg_environment_reset #623992
+ default
+
+ # https://bugs.gentoo.org/744289
+ find -type f \( -name "Makefile.am" -o -name "configure.ac" \) -print0 \
+ | xargs --null sed "s@ -Werror@@" -i || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-btrfs
+ --with-fs
+ --with-part
+ --with-python3
+ --without-mpath
+ --without-nvdimm
+ --without-python2
+ $(use_enable introspection)
+ $(use_enable test tests)
+ $(use_with bcache)
+ $(use_with cryptsetup crypto)
+ $(use_with device-mapper dm)
+ $(use_with dmraid)
+ $(use_with escrow)
+ $(use_with gtk-doc)
+ $(use_with kbd)
+ $(use_with lvm lvm)
+ $(use_with lvm lvm-dbus)
+ $(use_with tools)
+ $(use_with vdo)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # See http://storaged.org/libblockdev/ch03.html
+ # The 'check' target just does Pylint.
+ # ... but it needs root.
+ emake test
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+ # This is installed even with USE=-lvm, but libbd_lvm are omitted so it
+ # doesn't work at all.
+ if ! use lvm ; then
+ rm -f "${ED}"/usr/bin/lvm-cache-stats || die
+ fi
+ python_optimize #718576
+}
diff --git a/sys-libs/libblockdev/libblockdev-9999.ebuild b/sys-libs/libblockdev/libblockdev-9999.ebuild
index ab7407f4a420..a97f68fef26d 100644
--- a/sys-libs/libblockdev/libblockdev-9999.ebuild
+++ b/sys-libs/libblockdev/libblockdev-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit autotools python-single-r1 xdg-utils
DESCRIPTION="A library for manipulating block devices"
@@ -16,11 +16,8 @@ if [[ "${PV}" == *9999 ]] ; then
"
else
MY_PV="${PV}-1"
- #MY_P="${PN}-${MY_PV}"
- #SRC_URI="https://github.com/storaged-project/${PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
SRC_URI="https://github.com/storaged-project/${PN}/releases/download/${MY_PV}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
- #S="${WORKDIR}/${MY_P}"
fi
LICENSE="LGPL-2+"
SLOT="0"