summaryrefslogtreecommitdiff
path: root/sys-libs/libblockdev/libblockdev-3.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-28 10:54:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-28 10:54:09 +0000
commit3e690338421a6b64f6f44aa03db7416d75e0633a (patch)
treecb3907b4dfbc040edc539fd00645e851b14084bb /sys-libs/libblockdev/libblockdev-3.0.4.ebuild
parenta6f8a4117d60ec2919f9b312dcb0b7baa6c58ab9 (diff)
gentoo auto-resync : 28:11:2023 - 10:54:09
Diffstat (limited to 'sys-libs/libblockdev/libblockdev-3.0.4.ebuild')
-rw-r--r--sys-libs/libblockdev/libblockdev-3.0.4.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/sys-libs/libblockdev/libblockdev-3.0.4.ebuild b/sys-libs/libblockdev/libblockdev-3.0.4.ebuild
index 96fa6a0cbf98..aeb98f682a8e 100644
--- a/sys-libs/libblockdev/libblockdev-3.0.4.ebuild
+++ b/sys-libs/libblockdev/libblockdev-3.0.4.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit autotools python-single-r1 xdg-utils
DESCRIPTION="A library for manipulating block devices"
@@ -22,9 +22,7 @@ fi
LICENSE="LGPL-2+"
SLOT="0/3" # subslot is SOVERSION
IUSE="+cryptsetup device-mapper escrow gtk-doc introspection lvm +nvme test +tools"
-# Tests require root. In a future release, we may be able to run a smaller
-# subset with new run_tests.py arguments.
-RESTRICT="!test? ( test ) test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/glib-2.42.2
@@ -70,7 +68,13 @@ BDEPEND+="
"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
- escrow? ( cryptsetup )"
+ escrow? ( cryptsetup )
+ test? ( introspection lvm )
+"
+
+PATCHES=(
+ "${FILESDIR}/libblockdev-3.0.4-add-non-systemd-method-for-distro-info.patch"
+)
pkg_setup() {
python-single-r1_pkg_setup
@@ -111,9 +115,8 @@ src_configure() {
src_test() {
# See http://storaged.org/libblockdev/ch03.html
- # The 'check' target just does Pylint.
- # ... but it needs root.
- emake test
+ # Largest subset which doesn't require root priviledges
+ ${EPYTHON} tests/run_tests.py --include-tags extradeps sourceonly || die
}
src_install() {