summaryrefslogtreecommitdiff
path: root/sys-libs/kpmcore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /sys-libs/kpmcore
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'sys-libs/kpmcore')
-rw-r--r--sys-libs/kpmcore/Manifest2
-rw-r--r--sys-libs/kpmcore/kpmcore-4.0.1.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-libs/kpmcore/Manifest b/sys-libs/kpmcore/Manifest
index 9ff26c146a88..a8babb84025c 100644
--- a/sys-libs/kpmcore/Manifest
+++ b/sys-libs/kpmcore/Manifest
@@ -1,3 +1,5 @@
DIST kpmcore-4.0.0.tar.xz 417784 BLAKE2B deffb82b3ec5029ce845a398728b31b4da1b1b69377684a982b0d8067cfddc9ccb2ab2f4369faeb289b4aa54841940aae5a69051a30e4895b840c51393b0c487 SHA512 16f0a8ecae35c214272f28c49b5fff3d2d5e0959b9dceba392b9b6186d44e10d11fcf16ef0ad1da42f49f0c631ccb858d726a92d7c2f22125dae07fd4d2c5500
+DIST kpmcore-4.0.1.tar.xz 416932 BLAKE2B db429a9a51baf2d3f83d36479c05ac28c1d742dfc9e0dda51486d17958c95751da6295fe9e915359717eebbab3877464284b871dd8ded5a87c01c590cf4eac85 SHA512 982ad77246f59ade74edba15effca6490ac9ac7bb6db7f6194bcdbfddfa735c9bc1b58020affccd945fcdfc96fce3488167f492d6a13dcd6d19c5692505303ac
EBUILD kpmcore-4.0.0.ebuild 844 BLAKE2B c00be8ec09e14d56485588e343733027536eb07c79fd5513e81a9da223c608423bfd59676d27a235698a17e12be1b043d3b48f9878f4dcfe01af24ad9c03c294 SHA512 633c53cee2cef545b816da77e712bad4ac2da3dfe251ac31203ed700ebc486aad3ae738fc71710cabb065da750adcafa3b6002e6580b184eb7afe5f1b2937138
+EBUILD kpmcore-4.0.1.ebuild 820 BLAKE2B 9ab00e632080f0e814687bdcd15b5ff05a56a3e2d29b61a23da34b1c117bbfa3536fff3590a0e8e2ce6d50517b8955f742b4039bdd78029005ba47db5e2b553d SHA512 979fd99c05cbcb12520789f303a066ec881a15484aed24c17f3fc4806d4566310b8b7921d42cedad5cff28c85b3420680b647b7f1797771c82b6561eeefcb54d
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/sys-libs/kpmcore/kpmcore-4.0.1.ebuild b/sys-libs/kpmcore/kpmcore-4.0.1.ebuild
new file mode 100644
index 000000000000..9e74614109c4
--- /dev/null
+++ b/sys-libs/kpmcore/kpmcore-4.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Library for managing partitions"
+HOMEPAGE="https://kde.org/applications/system/org.kde.partitionmanager"
+LICENSE="GPL-3"
+SLOT="5/8"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ || (
+ app-crypt/qca[botan]
+ app-crypt/qca[ssl]
+ )
+ >=sys-apps/util-linux-2.33.2
+"
+RDEPEND="${DEPEND}"
+
+# bug 689468, tests need polkit etc.
+RESTRICT+=" test"