summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-2.39-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-12 00:45:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-12 00:45:59 +0000
commit2c3b9bbdb114cc13b6ef8e0e5933c9e374fca8b6 (patch)
tree04352a23e7dcea5171eafee655c62e4b2f24afbf /sys-libs/glibc/glibc-2.39-r2.ebuild
parent72d7e048ae88be323a380e2eae52dfda0b2dc1c0 (diff)
gentoo auto-resync : 12:03:2024 - 00:45:59
Diffstat (limited to 'sys-libs/glibc/glibc-2.39-r2.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.39-r2.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.39-r2.ebuild b/sys-libs/glibc/glibc-2.39-r2.ebuild
index b176c2198555..236484af1eeb 100644
--- a/sys-libs/glibc/glibc-2.39-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.39-r2.ebuild
@@ -512,8 +512,12 @@ setup_flags() {
# should not be a problem, but for glibc it matters as it is
# dealing with CET in ld.so. So if CET is supposed to be
# disabled for glibc, be explicit about it.
- if (use amd64 || use x86) && ! use cet; then
- append-flags '-fcf-protection=none'
+ if ! use cet; then
+ if use amd64 || use x86; then
+ append-flags '-fcf-protection=none'
+ elif use arm64; then
+ append-flags '-mbranch-protection=none'
+ fi
fi
}