summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-2.31-r7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
commitd2ed973482fdd800013658e83a61709b29e0a80f (patch)
tree57ea7666a57b5a05a4c8866e4915e90b4a6e7c94 /sys-libs/glibc/glibc-2.31-r7.ebuild
parent9f6a82a85d400d6ae7de04c43cee88dbc6bc4da0 (diff)
gentoo auto-resync : 27:06:2024 - 07:59:39
Diffstat (limited to 'sys-libs/glibc/glibc-2.31-r7.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.31-r7.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.31-r7.ebuild b/sys-libs/glibc/glibc-2.31-r7.ebuild
index 2625a376cfa0..e531ada0b011 100644
--- a/sys-libs/glibc/glibc-2.31-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.31-r7.ebuild
@@ -649,7 +649,7 @@ sanity_prechecks() {
# we test for...
if ! is_crosscompile ; then
if use amd64 && use multilib && [[ ${MERGE_TYPE} != "binary" ]] ; then
- ebegin "Checking that IA32 emulation is enabled in the running kernel"
+ ebegin "Checking if the system can execute 32-bit binaries"
echo 'int main(){return 0;}' > "${T}/check-ia32-emulation.c"
local STAT
if "${CC-${CHOST}-gcc}" ${CFLAGS_x86} "${T}/check-ia32-emulation.c" -o "${T}/check-ia32-emulation.elf32"; then
@@ -663,7 +663,11 @@ sanity_prechecks() {
fi
rm -f "${T}/check-ia32-emulation.elf32"
eend $STAT
- [[ $STAT -eq 0 ]] || die "CONFIG_IA32_EMULATION must be enabled in the kernel to compile a multilib glibc."
+ if [[ $STAT -ne 0 ]]; then
+ eerror "Ensure that CONFIG_IA32_EMULATION is enabled in the kernel."
+ eerror "Seek support otherwise."
+ die "Unable to execute 32-bit binaries"
+ fi
fi
fi