summaryrefslogtreecommitdiff
path: root/sys-libs/efivar/efivar-30.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-libs/efivar/efivar-30.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-libs/efivar/efivar-30.ebuild')
-rw-r--r--sys-libs/efivar/efivar-30.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-libs/efivar/efivar-30.ebuild b/sys-libs/efivar/efivar-30.ebuild
new file mode 100644
index 000000000000..b50a9b12bb88
--- /dev/null
+++ b/sys-libs/efivar/efivar-30.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tools and library to manipulate EFI variables"
+HOMEPAGE="https://github.com/rhinstaller/efivar"
+SRC_URI="https://github.com/rhinstaller/efivar/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/1"
+KEYWORDS="amd64 ~arm64 ia64 x86"
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-3.18
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ sed -i -e s/-Werror// gcc.specs || die
+}
+
+src_configure() {
+ tc-export CC
+
+ # https://github.com/rhinstaller/efivar/issues/64
+ append-cflags -flto
+
+ tc-ld-disable-gold
+ export libdir="/usr/$(get_libdir)"
+ unset LIBS # Bug 562004
+}
+
+src_compile() {
+ # Avoid building static binary/libs
+ opts=(
+ BINTARGETS=efivar
+ STATICLIBTARGETS=
+ )
+ emake "${opts[@]}"
+}
+
+src_install() {
+ emake "${opts[@]}" DESTDIR="${D}" install
+}