summaryrefslogtreecommitdiff
path: root/sys-libs/db/db-6.2.38-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /sys-libs/db/db-6.2.38-r1.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'sys-libs/db/db-6.2.38-r1.ebuild')
-rw-r--r--sys-libs/db/db-6.2.38-r1.ebuild45
1 files changed, 9 insertions, 36 deletions
diff --git a/sys-libs/db/db-6.2.38-r1.ebuild b/sys-libs/db/db-6.2.38-r1.ebuild
index 786041b37bd1..de6a736bdf14 100644
--- a/sys-libs/db/db-6.2.38-r1.ebuild
+++ b/sys-libs/db/db-6.2.38-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit db flag-o-matic java-pkg-opt-2 autotools multilib multilib-minimal eapi7-ver toolchain-funcs
+inherit db flag-o-matic autotools multilib multilib-minimal versionator eapi7-ver toolchain-funcs
#Number of official patches
#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
@@ -30,31 +30,22 @@ done
LICENSE="AGPL-3"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc java cxx tcl test"
+IUSE="doc cxx tcl test"
REQUIRED_USE="test? ( tcl )"
# the entire testsuite needs the TCL functionality
DEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
test? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
- java? ( >=virtual/jdk-1.8 )
kernel_linux? ( >=sys-devel/binutils-2.16.1 )
kernel_SunOS? ( >=sys-devel/binutils-2.16.1 )"
-RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
- java? ( >=virtual/jre-1.8 )"
+RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )"
MULTILIB_WRAPPED_HEADERS=(
/usr/include/db$(ver_cut 1-2)/db.h
)
PATCHES=(
- # bug #510506
- "${FILESDIR}"/${PN}-4.8.24-java-manifest-location.patch
-
- # use the includes from the prefix
- "${FILESDIR}"/${PN}-6.2.32-jni-check-prefix-first.patch
- "${FILESDIR}"/${PN}-4.2-listen-to-java-options.patch
-
# sqlite configure call has an extra leading ..
# upstreamed:5.2.36, missing in 5.3.x/6.x
# still needs to be patched in 6.0.20
@@ -63,6 +54,8 @@ PATCHES=(
# The upstream testsuite copies .lib and the binaries for each parallel test
# core, ~300MB each. This patch uses links instead, saves a lot of space.
"${FILESDIR}"/${PN}-6.0.20-test-link.patch
+
+ "${FILESDIR}"/${PN}-6.2.38-bashism-configure.patch
)
src_prepare() {
@@ -83,12 +76,6 @@ src_prepare() {
-e "/^DB_RELEASE_DATE=/s~=.*~='${REAL_DB_RELEASE_DATE}'~g" \
"${S_BASE}"/dist/RELEASE || die
- # Include the SLOT for Java JAR files
- # This supersedes the unused jarlocation patches.
- sed -r -i \
- -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
- "${S_BASE}"/dist/Makefile.in || die
-
cd "${S_BASE}"/dist || die
rm -f aclocal/libtool.m4
sed -i \
@@ -97,8 +84,8 @@ src_prepare() {
sed -i \
-e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
aclocal/programs.m4 || die
- AT_M4DIR="aclocal aclocal_java" eautoreconf
- # Upstream sucks - they do autoconf and THEN replace the version variables.
+ AT_M4DIR="aclocal" eautoreconf
+ # They do autoconf and THEN replace the version variables :(
. ./RELEASE
for v in \
DB_VERSION_{FAMILY,LETTER,RELEASE,MAJOR,MINOR} \
@@ -130,11 +117,11 @@ multilib_src_configure() {
--disable-sql_codegen
--disable-sql_compat
--disable-static
+ --disable-java
$([[ ${ABI} == arm ]] && echo --with-mutex=ARM/gcc-assembly)
$([[ ${ABI} == amd64 ]] && echo --with-mutex=x86/gcc-assembly)
$(use_enable cxx)
$(use_enable cxx stl)
- $(multilib_native_use_enable java)
$(use_enable test)
)
@@ -153,14 +140,6 @@ multilib_src_configure() {
append-ldflags -Wl,--default-symver
fi
- # use `set` here since the java opts will contain whitespace
- if multilib_is_native_abi && use java ; then
- myeconfargs+=(
- --with-java-prefix="${JAVA_HOME}"
- --with-javac-flags="$(java-pkg_javac-args)"
- )
- fi
-
# Bug #270851: test needs TCL support
if use tcl || use test ; then
myeconfargs+=(
@@ -182,12 +161,6 @@ multilib_src_install() {
db_src_install_headerslot
db_src_install_usrlibcleanup
-
- if multilib_is_native_abi && use java; then
- java-pkg_regso "${ED%/}"/usr/"$(get_libdir)"/libdb_java*.so
- java-pkg_dojar "${ED%/}"/usr/"$(get_libdir)"/*.jar
- rm -f "${ED%/}"/usr/"$(get_libdir)"/*.jar
- fi
}
multilib_src_install_all() {