summaryrefslogtreecommitdiff
path: root/sys-libs/compiler-rt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-11 21:30:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-11 21:30:43 +0000
commit7236d0a40beeff3f6f0fcede52d54dfb81880faa (patch)
tree5eb555a5b67950ef35c1149881ab3fb6b6eba836 /sys-libs/compiler-rt
parent469b5d8f31adfd054c5c493fc3df2f9c89c9fa00 (diff)
gentoo auto-resync : 11:11:2022 - 21:30:43
Diffstat (limited to 'sys-libs/compiler-rt')
-rw-r--r--sys-libs/compiler-rt/Manifest2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-16.0.0.9999.ebuild4
2 files changed, 3 insertions, 3 deletions
diff --git a/sys-libs/compiler-rt/Manifest b/sys-libs/compiler-rt/Manifest
index 187b18c35b86..b69dec312ff3 100644
--- a/sys-libs/compiler-rt/Manifest
+++ b/sys-libs/compiler-rt/Manifest
@@ -16,6 +16,6 @@ EBUILD compiler-rt-14.0.6-r1.ebuild 4247 BLAKE2B 42673c116b115622e192ae5629e2711
EBUILD compiler-rt-15.0.3.ebuild 4259 BLAKE2B b14a1d7d6d7d6ba021074ca6c22d6a0db1a61d2d9b16d7391a5321832f67237514d002cb269ea0cfcced8fe6992db96551c87fdf3e15975798c73283fcf92964 SHA512 43dd2e1f6687c6ab7a640ee68994f449aba5229e9e29d54f34afa5be006b2cc0a1768997be705ccf93209f2ec970ef9f47b61f364f5218baf5e0a8116b8855e4
EBUILD compiler-rt-15.0.4.9999.ebuild 4189 BLAKE2B da1b3444520bbb7a83569b65d7de338678a52b2aec70d29afee47142a268fb76310419dd00d1420445d2f30d3f567cf2bfe9e89cf89261843742094d477a2ef6 SHA512 d29905eca230cdba53aa9d63d1ccb68608b4ca74c4a6c3fbcab60245685c363d93e28ea3dba67f632c85964571da5c812ab8ca6c6be2bf97d06c93c072f75153
EBUILD compiler-rt-15.0.4.ebuild 4264 BLAKE2B 7411477bbdf896d3cd8bd112b0aaf0fc92b21813b2808474571f90eb1b2bdcd1e617b6262267c3adb90c9993c7f0e5d326aac1430440873cbb2be1644499c156 SHA512 0dd3a2e968a4698bff0d617b710046e824fc219ce33998012cdf0bb62c56e2ff159122e39c0203a042e59c5f7f693dae8ea5dcccd4115871e0bd8b54f01469e0
-EBUILD compiler-rt-16.0.0.9999.ebuild 4189 BLAKE2B da1b3444520bbb7a83569b65d7de338678a52b2aec70d29afee47142a268fb76310419dd00d1420445d2f30d3f567cf2bfe9e89cf89261843742094d477a2ef6 SHA512 d29905eca230cdba53aa9d63d1ccb68608b4ca74c4a6c3fbcab60245685c363d93e28ea3dba67f632c85964571da5c812ab8ca6c6be2bf97d06c93c072f75153
+EBUILD compiler-rt-16.0.0.9999.ebuild 4185 BLAKE2B 5fd8276217f6965247d77d953d37989833e11a5a08ebd11180dc12ea3745c89b2c90b016abd52ca7b0823f1ff198468aac8ad30bd4f1c8728e5028ca6d7a83b5 SHA512 d36c26715308dd2fee7aea19ca522a65356889eaf21ebd88dc83eead883b7b5d35864cb958fa97bd84c99cd178d39170308a4c411f188a5ee4801501f198d9a3
EBUILD compiler-rt-16.0.0_pre20221104.ebuild 4189 BLAKE2B da1b3444520bbb7a83569b65d7de338678a52b2aec70d29afee47142a268fb76310419dd00d1420445d2f30d3f567cf2bfe9e89cf89261843742094d477a2ef6 SHA512 d29905eca230cdba53aa9d63d1ccb68608b4ca74c4a6c3fbcab60245685c363d93e28ea3dba67f632c85964571da5c812ab8ca6c6be2bf97d06c93c072f75153
MISC metadata.xml 416 BLAKE2B 79a58249c94b605ba57f346c4e05b43853cf6cfb8bb65a4f4e3c44039cccfdb83dd31bfaaaf398bcbdc393efabdfc7ed186fe775976c46227e74decf2c8f4fb2 SHA512 ce30c79a575e5933effb1fec36f9a4ef02d9f97f312feb39c55a88cbda9a1bae1d7af2ec4ad5f66212cbb2cdbfb26f1a436689f16f410153c9d65eb010264c48
diff --git a/sys-libs/compiler-rt/compiler-rt-16.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-16.0.0.9999.ebuild
index 957caa27a746..f2f66ffb0a25 100644
--- a/sys-libs/compiler-rt/compiler-rt-16.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-16.0.0.9999.ebuild
@@ -10,7 +10,7 @@ DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
-SLOT="${LLVM_VERSION}"
+SLOT="${LLVM_MAJOR}"
KEYWORDS=""
IUSE="+abi_x86_32 abi_x86_64 +clang debug test"
RESTRICT="!test? ( test ) !clang? ( test )"
@@ -96,7 +96,7 @@ src_configure() {
fi
local mycmakeargs=(
- -DCOMPILER_RT_INSTALL_PATH="${EPREFIX}/usr/lib/clang/${LLVM_VERSION}"
+ -DCOMPILER_RT_INSTALL_PATH="${EPREFIX}/usr/lib/clang/${LLVM_MAJOR}"
-DCOMPILER_RT_INCLUDE_TESTS=$(usex test)
-DCOMPILER_RT_BUILD_LIBFUZZER=OFF