summaryrefslogtreecommitdiff
path: root/sys-libs/compiler-rt/compiler-rt-13.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /sys-libs/compiler-rt/compiler-rt-13.0.0.9999.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-13.0.0.9999.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.0.9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.0.9999.ebuild
index f726db78861b..d6a1a16eb346 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.0.9999.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
KEYWORDS=""
-IUSE="+clang test"
+IUSE="+clang debug test"
RESTRICT="!test? ( test ) !clang? ( test )"
CLANG_SLOT=${SLOT%%.*}
@@ -60,6 +60,9 @@ test_compiler() {
}
src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
# pre-set since we need to pass it to cmake
BUILD_DIR=${WORKDIR}/${P}_build