summaryrefslogtreecommitdiff
path: root/sys-libs/blocksruntime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /sys-libs/blocksruntime
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'sys-libs/blocksruntime')
-rw-r--r--sys-libs/blocksruntime/Manifest4
-rw-r--r--sys-libs/blocksruntime/blocksruntime-0_pre20171027.ebuild41
-rw-r--r--sys-libs/blocksruntime/files/blocksruntime-0_pre20171027-ldflags-soname.patch34
-rw-r--r--sys-libs/blocksruntime/metadata.xml11
4 files changed, 90 insertions, 0 deletions
diff --git a/sys-libs/blocksruntime/Manifest b/sys-libs/blocksruntime/Manifest
new file mode 100644
index 000000000000..e1d36758f7b9
--- /dev/null
+++ b/sys-libs/blocksruntime/Manifest
@@ -0,0 +1,4 @@
+AUX blocksruntime-0_pre20171027-ldflags-soname.patch 933 BLAKE2B 335a135b321bc57cfd63afa0c40ae91316dc5f446c4c412270ab78f3a2b9ee435900ebcdd8bb57dbd60d6a3d0bc412825a7f344141f3ef8ef6a042f29af34cc8 SHA512 7887727d2005dc70dee37b3dadbe49deeb9de7013e2d49f80248f71211a45f70e9a986991eb9bfc93668d635698f40504072fefdfca88511f8fc39121ba6f8f6
+DIST blocksruntime-0_pre20171027.tar.gz 40571 BLAKE2B 5cb5cee10d482a3028b6ed496f7ed4fba25504c5e188dd21be37f0a65b72750e0ce31f7243e9cd848d10323e43e7d058fd2f7eb5ffed9a64e543d418ac96cfac SHA512 4008730f7ee4173f22c40220c4b87cd3f5cfadd12d5ddbaec244e3c4164111f036d0b859cf4bb5f2425313148f5c6445de30af2d4ccc83e1b97a66895ccc6dc5
+EBUILD blocksruntime-0_pre20171027.ebuild 905 BLAKE2B 60f6b3e05c433843c60238a64049cd6b1be61ff1bf5619e6e41989a43a51735f7e1c845edf9005e3becbb8cbe4e6c50ee2509bed81400b84161a5c8600f96010 SHA512 667e95c61e777c99057eedb2ebc197b6a584f2c0bcbd417065f66cccc86834564aa78226b7183a00c9beed5e665bca8530cba745d56cc0f2ec077fbc07c4a864
+MISC metadata.xml 337 BLAKE2B e2e4dc3f4bf390d4cd54194e85e6e2104e962d0ddd7b7381ddb7e1974c778bfe7d86162087b267faff5c306a6583b9ac092a79305e750ab6b1dbab758c6e780e SHA512 3dcbdca3013c551d20488c1b2d53525c5bc4e234403a2051c0dd8e7ad9db15f9cc946778764e1bf4aa19816a66a3922ed879614c01e46265195535fa91ebc481
diff --git a/sys-libs/blocksruntime/blocksruntime-0_pre20171027.ebuild b/sys-libs/blocksruntime/blocksruntime-0_pre20171027.ebuild
new file mode 100644
index 000000000000..a855b832dba2
--- /dev/null
+++ b/sys-libs/blocksruntime/blocksruntime-0_pre20171027.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs vcs-snapshot
+
+COMMIT=9cc93ae2b58676c23fd02cf0c686fa15b7a3ff81 # 27 Oct 2017
+
+DESCRIPTION="BlocksRuntime library needed for clang's -fblocks support"
+HOMEPAGE="https://github.com/mackyle/blocksruntime"
+SRC_URI="https://github.com/mackyle/blocksruntime/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0_pre20171027-ldflags-soname.patch
+)
+
+src_prepare() {
+ default
+
+ tc-export CC AR RANLIB
+}
+
+src_compile() {
+ ./buildlib -shared || die
+}
+
+src_install() {
+ prefix="${EPREFIX}/usr" \
+ libdir="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" \
+ ./installlib $(use static-libs || echo -shared) || die
+}
diff --git a/sys-libs/blocksruntime/files/blocksruntime-0_pre20171027-ldflags-soname.patch b/sys-libs/blocksruntime/files/blocksruntime-0_pre20171027-ldflags-soname.patch
new file mode 100644
index 000000000000..66e9f1993bd8
--- /dev/null
+++ b/sys-libs/blocksruntime/files/blocksruntime-0_pre20171027-ldflags-soname.patch
@@ -0,0 +1,34 @@
+--- a/buildlib
++++ b/buildlib
+@@ -28,11 +28,13 @@ if [ -n "$shared" ]; then
+ SHLIB="${LIB%.a}.dylib"
+ SHOPT="-dynamiclib -Wl,-all_load"
+ SHOPT2=
++ SONAME=
+ ;;
+ *)
+ SHLIB="${LIB%.a}.so"
+ SHOPT="-shared -Wl,-whole-archive"
+ SHOPT2="-Wl,-no-whole-archive"
++ SONAME="-Wl,-soname=${SHLIB}.0"
+ ;;
+ esac
+ fi
+@@ -108,5 +110,5 @@ echo "SRC=$SRC"
+ [ -z "$shared" ] ||
+ (
+ PS4= && set -ex
+- "$CC" $FPIC $CFLAGS -o "$SHLIB" $SHOPT $LIB $SHOPT2
++ "$CC" $FPIC $CFLAGS $LDFLAGS -o "$SHLIB" $SHOPT $LIB $SHOPT2 ${SONAME}
+ ) || exit
+--- a/installlib
++++ b/installlib
+@@ -91,5 +91,7 @@ docmd "install -d "$DESTDIR"$includedir "$DESTDIR"$libdir"
+ docmd "install -m 644 $HEADER "$DESTDIR"$includedir/"
+ [ -z "$LIB" ] ||
+ docmd "install -m 644 $LIB "$DESTDIR"$libdir/"
+-[ -z "$SHLIB" ] ||
++[ -z "$SHLIB" ] || {
+ docmd "install -m $SHLIBMODE $SHLIB "$DESTDIR"$libdir/"
++docmd "ln -s $SHLIB "$DESTDIR"$libdir/${SHLIB}.0"
++}
diff --git a/sys-libs/blocksruntime/metadata.xml b/sys-libs/blocksruntime/metadata.xml
new file mode 100644
index 000000000000..4ce153662dd9
--- /dev/null
+++ b/sys-libs/blocksruntime/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>slyfox@gentoo.org</email>
+ <name>Sergei Trofimovich</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mackyle/blocksruntime</remote-id>
+ </upstream>
+</pkgmetadata>