summaryrefslogtreecommitdiff
path: root/sys-libs/blocksruntime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
commit1c33e521c460dc40899ce7bc919602b842ce27e2 (patch)
tree580eefad4cce1e883e7504b93352a9029b53036d /sys-libs/blocksruntime
parent65e4244e411c4f65f55f2aa91f39e228f4c0680b (diff)
gentoo auto-resync : 05:03:2023 - 23:52:45
Diffstat (limited to 'sys-libs/blocksruntime')
-rw-r--r--sys-libs/blocksruntime/Manifest1
-rw-r--r--sys-libs/blocksruntime/blocksruntime-0_pre20171027-r2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-libs/blocksruntime/Manifest b/sys-libs/blocksruntime/Manifest
index 57142524a541..0c797c28bc7d 100644
--- a/sys-libs/blocksruntime/Manifest
+++ b/sys-libs/blocksruntime/Manifest
@@ -1,4 +1,5 @@
AUX blocksruntime-0_pre20171027-ldflags-soname.patch 933 BLAKE2B 335a135b321bc57cfd63afa0c40ae91316dc5f446c4c412270ab78f3a2b9ee435900ebcdd8bb57dbd60d6a3d0bc412825a7f344141f3ef8ef6a042f29af34cc8 SHA512 7887727d2005dc70dee37b3dadbe49deeb9de7013e2d49f80248f71211a45f70e9a986991eb9bfc93668d635698f40504072fefdfca88511f8fc39121ba6f8f6
DIST blocksruntime-0_pre20171027.tar.gz 40571 BLAKE2B 5cb5cee10d482a3028b6ed496f7ed4fba25504c5e188dd21be37f0a65b72750e0ce31f7243e9cd848d10323e43e7d058fd2f7eb5ffed9a64e543d418ac96cfac SHA512 4008730f7ee4173f22c40220c4b87cd3f5cfadd12d5ddbaec244e3c4164111f036d0b859cf4bb5f2425313148f5c6445de30af2d4ccc83e1b97a66895ccc6dc5
EBUILD blocksruntime-0_pre20171027-r1.ebuild 980 BLAKE2B 51116077a0f71392e579265c407179a361976cd63c5d2d83136c5dbdd58d9965f7b1f6e8ca7f6700a6dcad439d4a5632d9cc17105f25679da8e7499c29b9e5eb SHA512 5ca0ab3e205cd86f37149b50c6c93ae66e5c5d0c31e287e31969bf7c59ec355c86f745f61a8682db2fe30311e504be38fd2f95752975114f466009669944e115
+EBUILD blocksruntime-0_pre20171027-r2.ebuild 1003 BLAKE2B 1c489c3688ff749c4ca3c70318c26b39d61cf0f4bc8e4e19d6c42c8c3e5d2a986e593d0e2ed1bdc521fffda66adc5df89de628c715f2c32a4ad025038d3a4e55 SHA512 cc3f2bc3abc80de7b577a2f54c0aa82f16b10f417fd94d4c372d14673c28a31ebaacf220a07a6aadb7398543fedb528616496c9a4f01515b048d7ed6b7eee8a6
MISC metadata.xml 332 BLAKE2B a3c555c588394e389edd5c930a13242db36a0dac93d63c994d018f122e81fb91357a9aa7339a496c7818acac13c3934ca48e1131399deafd7f941409b5bc0c9a SHA512 e0b7bc8f099e953f31f15ddfbbde6fc721d0fcf562cfa58dd72006bb0018705de71324906fc9776f1ca89176798908739662686b60d79cedbd315b7539b581b8
diff --git a/sys-libs/blocksruntime/blocksruntime-0_pre20171027-r2.ebuild b/sys-libs/blocksruntime/blocksruntime-0_pre20171027-r2.ebuild
new file mode 100644
index 000000000000..1036aca20985
--- /dev/null
+++ b/sys-libs/blocksruntime/blocksruntime-0_pre20171027-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs vcs-snapshot
+
+COMMIT=9cc93ae2b58676c23fd02cf0c686fa15b7a3ff81 # 27 Oct 2017
+
+DESCRIPTION="BlocksRuntime library needed for clang's -fblocks support"
+HOMEPAGE="https://github.com/mackyle/blocksruntime"
+SRC_URI="https://github.com/mackyle/blocksruntime/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="!dev-libs/libdispatch"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0_pre20171027-ldflags-soname.patch
+)
+
+src_prepare() {
+ default
+
+ tc-export CC AR RANLIB
+}
+
+src_compile() {
+ ./buildlib -shared || die
+}
+
+src_install() {
+ prefix="${EPREFIX}/usr" \
+ includedir="${EPREFIX}/usr/include/blocksruntime" \
+ libdir="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" \
+ ./installlib $(use static-libs || echo -shared) || die
+}