summaryrefslogtreecommitdiff
path: root/sys-libs/argp-standalone/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-24 20:03:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-24 20:03:07 +0000
commitec9f79e1d3358df31a704f16a76a269ccceae2b2 (patch)
tree5982c029d09bc9e396ad5ead3d99c99ed6a58322 /sys-libs/argp-standalone/files
parent9aefa814d833d6bdd1bdbc7d0f44d5680c9beaa8 (diff)
gentoo auto-resync : 24:12:2022 - 20:03:07
Diffstat (limited to 'sys-libs/argp-standalone/files')
-rw-r--r--sys-libs/argp-standalone/files/argp-standalone-1.3-shared.patch54
-rw-r--r--sys-libs/argp-standalone/files/argp-standalone-1.3-throw-in-funcdef.patch79
2 files changed, 0 insertions, 133 deletions
diff --git a/sys-libs/argp-standalone/files/argp-standalone-1.3-shared.patch b/sys-libs/argp-standalone/files/argp-standalone-1.3-shared.patch
deleted file mode 100644
index eea801c4ee98..000000000000
--- a/sys-libs/argp-standalone/files/argp-standalone-1.3-shared.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-Initially added in https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cb196546c62e9894a46900e8078f753388d4cc1a.
-Commit mentions it being from Debian but not found any other references yet.
-
-We use -largp fairly extensively across the tree which this patch
-accommodates (easier than forcing includes?).
---- a/Makefile.am 2009-05-28 15:19:50.000000000 +0200
-+++ b/Makefile.am 2009-05-28 15:30:57.000000000 +0200
-@@ -21,20 +21,20 @@
- AUTOMAKE_OPTIONS = foreign
- SUBDIRS = . testsuite
-
--LIBOBJS = @LIBOBJS@
-+LTLIBOBJS = @LTLIBOBJS@
-
--noinst_LIBRARIES = libargp.a
-+lib_LTLIBRARIES = libargp.la
- noinst_PROGRAMS = argp-test
- noinst_HEADERS = argp.h argp-fmtstream.h argp-namefrob.h # argp-comp.h
-
- EXTRA_DIST = mempcpy.c strchrnul.c strndup.c Versions
-
- # Leaves out argp-fs-xinl.c and argp-xinl.c
--libargp_a_SOURCES = argp-ba.c argp-eexst.c argp-fmtstream.c \
-+libargp_la_SOURCES = argp-ba.c argp-eexst.c argp-fmtstream.c \
- argp-help.c argp-parse.c argp-pv.c \
- argp-pvh.c
-
--libargp_a_LIBADD = $(LIBOBJS)
-+libargp_la_LIBADD = $(LTLIBOBJS)
-
--argp_test_LDADD = libargp.a
-+argp_test_LDADD = libargp.la
-
---- a/configure.ac 2009-05-28 15:20:01.000000000 +0200
-+++ b/configure.ac 2009-05-28 15:21:06.000000000 +0200
-@@ -17,6 +17,7 @@
- AC_PROG_MAKE_SET
- AC_PROG_RANLIB
- AM_PROG_CC_STDC
-+AC_PROG_LIBTOOL
-
- if test "x$am_cv_prog_cc_stdc" = xno ; then
- AC_ERROR([the C compiler doesn't handle ANSI-C])
---- a/testsuite/Makefile.am 2009-05-28 15:21:33.000000000 +0200
-+++ b/testsuite/Makefile.am 2009-05-28 15:21:41.000000000 +0200
-@@ -5,7 +5,7 @@
-
- noinst_PROGRAMS = $(TS_PROGS) ex1 ex3 ex4
-
--LDADD = ../libargp.a
-+LDADD = -L../.libs -largp
-
- EXTRA_DIST = $(TS_SH) run-tests
- CLEANFILES = test.out
diff --git a/sys-libs/argp-standalone/files/argp-standalone-1.3-throw-in-funcdef.patch b/sys-libs/argp-standalone/files/argp-standalone-1.3-throw-in-funcdef.patch
deleted file mode 100644
index 4a90751e1e62..000000000000
--- a/sys-libs/argp-standalone/files/argp-standalone-1.3-throw-in-funcdef.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-# --- T2-COPYRIGHT-NOTE-BEGIN ---
-# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
-#
-# T2 SDE: package/.../rng-tools/throw-in-funcdef.patch.argp-standalone
-# Copyright (C) 2006 The T2 SDE Project
-#
-# More information can be found in the files COPYING and README.
-#
-# This patch file is dual-licensed. It is available under the license the
-# patched project is licensed under, as long as it is an OpenSource license
-# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
-# of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or (at your option) any later
-# version.
-# --- T2-COPYRIGHT-NOTE-END ---
-
-
-No __THROW in function implementation.
- --jsaw
-
---- argp-standalone-1.4-test2/argp.h.orig 2006-01-06 02:29:59.000000000 +0100
-+++ argp-standalone-1.4-test2/argp.h 2006-01-06 02:41:10.000000000 +0100
-@@ -560,17 +560,17 @@
- # endif
-
- # ifndef ARGP_EI
--# define ARGP_EI extern __inline__
-+# define ARGP_EI extern inline
- # endif
-
- ARGP_EI void
--__argp_usage (__const struct argp_state *__state) __THROW
-+__argp_usage (__const struct argp_state *__state)
- {
- __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
- }
-
- ARGP_EI int
--__option_is_short (__const struct argp_option *__opt) __THROW
-+__option_is_short (__const struct argp_option *__opt)
- {
- if (__opt->flags & OPTION_DOC)
- return 0;
-@@ -582,7 +582,7 @@
- }
-
- ARGP_EI int
--__option_is_end (__const struct argp_option *__opt) __THROW
-+__option_is_end (__const struct argp_option *__opt)
- {
- return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
- }
---- argp-standalone-1.4-test2/argp-parse.c.orig 2006-01-06 02:47:48.000000000 +0100
-+++ argp-standalone-1.4-test2/argp-parse.c 2006-01-06 02:48:16.000000000 +0100
-@@ -1290,13 +1290,13 @@
- /* Defined here, in case a user is not inlining the definitions in
- * argp.h */
- void
--__argp_usage (__const struct argp_state *__state) __THROW
-+__argp_usage (__const struct argp_state *__state)
- {
- __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
- }
-
- int
--__option_is_short (__const struct argp_option *__opt) __THROW
-+__option_is_short (__const struct argp_option *__opt)
- {
- if (__opt->flags & OPTION_DOC)
- return 0;
-@@ -1310,7 +1310,7 @@
- }
-
- int
--__option_is_end (__const struct argp_option *__opt) __THROW
-+__option_is_end (__const struct argp_option *__opt)
- {
- return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
- }