summaryrefslogtreecommitdiff
path: root/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201.ebuild')
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201.ebuild
new file mode 100644
index 000000000000..de796c6696ac
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+
+inherit kernel-2 eapi7-ver
+detect_version
+detect_arch
+
+MY_PV=$(ver_cut 4-)
+MY_PV=${MY_PV/p/}
+DESCRIPTION="Raspberry Pi kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+SRC_URI="https://github.com/raspberrypi/linux/archive/raspberrypi-kernel_1.${MY_PV}-1.tar.gz"
+S="${WORKDIR}/linux-raspberrypi-kernel_1.${MY_PV}-1"
+
+KEYWORDS="~arm ~arm64"
+
+src_unpack() {
+ default
+}