summaryrefslogtreecommitdiff
path: root/sys-kernel/pf-sources/pf-sources-5.17_p1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-kernel/pf-sources/pf-sources-5.17_p1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-kernel/pf-sources/pf-sources-5.17_p1.ebuild')
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.17_p1.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/sys-kernel/pf-sources/pf-sources-5.17_p1.ebuild b/sys-kernel/pf-sources/pf-sources-5.17_p1.ebuild
deleted file mode 100644
index 74098adff5b6..000000000000
--- a/sys-kernel/pf-sources/pf-sources-5.17_p1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Define what default functions to run
-ETYPE="sources"
-
-# No 'experimental' USE flag provided, but we still want to use genpatches
-K_EXP_GENPATCHES_NOUSE="1"
-
-# Just get basic genpatches, -pf patch set already includes vanilla-linux updates
-K_GENPATCHES_VER="1"
-
-# -pf already sets EXTRAVERSION to kernel Makefile
-K_NOSETEXTRAVERSION="1"
-
-# Not supported by the Gentoo security team
-K_SECURITY_UNSUPPORTED="1"
-
-# We want the very basic patches from gentoo-sources, experimental patch is
-# already included in pf-sources
-K_WANT_GENPATCHES="base extras"
-
-# major kernel version, e.g. 5.14
-SHPV="${PV/_p*/}"
-
-# https://gitlab.com/alfredchen/projectc/ revision for a major version,
-# e.g. prjc-v5.14-r2 = 2
-PRJC_R=1
-
-inherit kernel-2 optfeature
-detect_version
-
-DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
-HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
- https://dev.gentoo.org/~mpagano/genpatches/"
-SRC_URI="${KERNEL_URI}
- https://github.com/pfactum/pf-kernel/compare/v${SHPV}...v${SHPV}-pf${PV/*_p/}.diff -> ${P}.patch
- https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.base.tar.xz
- https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.extras.tar.xz
- https://dev.gentoo.org/~juippis/patches/pf-sources/${SHPV}/prjc-v${SHPV}-${PRJC_R}uo.patch"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-
-S="${WORKDIR}/linux-${PVR}-pf"
-
-PATCHES=( "${DISTDIR}/${P}.patch"
- "${DISTDIR}/prjc-v${SHPV}-${PRJC_R}uo.patch" )
-
-K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
- see: ${HOMEPAGE}."
-
-pkg_setup() {
- ewarn ""
- ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
- ewarn "If you need support, please contact the pf developers directly."
- ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
- ewarn "the ebuilds. Thank you."
- ewarn ""
-
- kernel-2_pkg_setup
-}
-
-src_prepare() {
- # kernel-2_src_prepare doesn't apply PATCHES().
- default
-}
-
-pkg_postinst() {
- kernel-2_pkg_postinst
-
- optfeature "userspace KSM helper" sys-process/uksmd
-}