summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-headers/linux-headers-5.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /sys-kernel/linux-headers/linux-headers-5.16.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-5.16.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-5.16.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-5.16.ebuild b/sys-kernel/linux-headers/linux-headers-5.16.ebuild
index 56a633840c3b..5a407e44b3c5 100644
--- a/sys-kernel/linux-headers/linux-headers-5.16.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-5.16.ebuild
@@ -5,7 +5,7 @@ EAPI=7
ETYPE="headers"
H_SUPPORTEDARCH="alpha amd64 arc arm arm64 avr32 cris frv hexagon hppa ia64 m68k metag microblaze mips mn10300 nios2 openrisc ppc ppc64 riscv s390 score sh sparc x86 xtensa"
-inherit kernel-2 toolchain-funcs
+inherit kernel-2
detect_version
PATCH_PV=${PV} # to ease testing new versions against not existing patches
@@ -31,11 +31,11 @@ src_unpack() {
}
src_prepare() {
- if use elibc_musl ; then
- # TODO: May need forward porting to newer versions
- eapply "${FILESDIR}"/${PN}-5.10-Use-stddefs.h-instead-of-compiler.h.patch
- eapply "${FILESDIR}"/${PN}-5.15-remove-inclusion-sysinfo.h.patch
- fi
+ # TODO: May need forward porting to newer versions
+ use elibc_musl && PATCHES+=(
+ "${FILESDIR}"/${PN}-5.10-Use-stddefs.h-instead-of-compiler.h.patch
+ "${FILESDIR}"/${PN}-5.15-remove-inclusion-sysinfo.h.patch
+ )
# avoid kernel-2_src_prepare
default
@@ -49,4 +49,6 @@ src_install() {
kernel-2_src_install
find "${ED}" \( -name '.install' -o -name '*.cmd' \) -delete || die
+ # delete empty directories
+ find "${ED}" -empty -type d -delete || die
}