summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-docs/linux-docs-6.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-30 00:07:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-30 00:07:18 +0100
commit0e2a727aba684f1a44cc0402a3f77d242140681b (patch)
treead462b91afc9d7f8d76e3c51331517fddd6b25c2 /sys-kernel/linux-docs/linux-docs-6.9.2.ebuild
parent5c4786a868bad6e3f46aecf32ad6c6dc5de98408 (diff)
gentoo auto-resync : 30:05:2024 - 00:07:18
Diffstat (limited to 'sys-kernel/linux-docs/linux-docs-6.9.2.ebuild')
-rw-r--r--sys-kernel/linux-docs/linux-docs-6.9.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-kernel/linux-docs/linux-docs-6.9.2.ebuild b/sys-kernel/linux-docs/linux-docs-6.9.2.ebuild
new file mode 100644
index 000000000000..ff2813f4dd85
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-6.9.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10,11,12} )
+inherit linux-info python-any-r1 toolchain-funcs
+
+MY_P=linux-${PV}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/kernel/v6.x/${MY_P}.tar.xz"
+
+S=${WORKDIR}/${MY_P}
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="graphviz"
+
+RDEPEND="graphviz? ( >=media-gfx/graphviz-5.0.0 )"
+
+BDEPEND="${PYTHON_DEPS}
+ >=dev-python/sphinx-7.2.3
+ dev-python/sphinx-rtd-theme
+ media-libs/fontconfig
+ $(python_gen_any_dep '
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+ ')"
+
+src_prepare() {
+ default
+ # Fix the Python shebangs.
+ python_fix_shebang "${S}/Documentation/sphinx/"
+}
+
+src_compile() {
+ local ARCH="$(tc-arch-kernel)"
+ unset KBUILD_OUTPUT
+ HTML_DOCS=( Documentation/output/. )
+ emake htmldocs
+}
+
+src_install() {
+ einstalldocs
+}