summaryrefslogtreecommitdiff
path: root/sys-kernel/installkernel/installkernel-12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-12 13:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-12 13:08:05 +0000
commit4c4e8e9bf6d1ef49be600d77fcbbd7be716aece7 (patch)
treec854c61724b1a5430091a4512ef763d26efe5938 /sys-kernel/installkernel/installkernel-12.ebuild
parent669bfefc6b9cafab1e89f098b21cf0f89c12d995 (diff)
gentoo auto-resync : 12:01:2024 - 13:08:05
Diffstat (limited to 'sys-kernel/installkernel/installkernel-12.ebuild')
-rw-r--r--sys-kernel/installkernel/installkernel-12.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-kernel/installkernel/installkernel-12.ebuild b/sys-kernel/installkernel/installkernel-12.ebuild
new file mode 100644
index 000000000000..042e7cbdf2d6
--- /dev/null
+++ b/sys-kernel/installkernel/installkernel-12.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Gentoo fork of installkernel script from debianutils"
+HOMEPAGE="https://github.com/projg2/installkernel-gentoo"
+SRC_URI="https://github.com/projg2/installkernel-gentoo/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-gentoo-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x86-linux"
+IUSE="+dracut grub uki ukify"
+
+RDEPEND="
+ >=sys-apps/debianutils-4.9-r1
+ !<sys-apps/debianutils-4.9-r1[installkernel(+)]
+ !sys-kernel/installkernel-systemd
+"
+
+src_install() {
+ into /
+ dosbin installkernel
+ doman installkernel.8
+ keepdir /etc/kernel/postinst.d
+ keepdir /etc/kernel/preinst.d
+
+ if use dracut; then
+ exeinto /etc/kernel/preinst.d
+ doexe hooks/50-dracut.install
+ fi
+
+ if use grub; then
+ exeinto /etc/kernel/postinst.d
+ doexe hooks/91-grub-mkconfig.install
+ fi
+
+ if use uki; then
+ exeinto /etc/kernel/postinst.d
+ doexe hooks/90-uki-copy.install
+ fi
+
+ if use ukify; then
+ exeinto /etc/kernel/preinst.d
+ doexe hooks/60-ukify.install
+ fi
+}
+
+pkg_postinst() {
+ if has 1 ${REPLACING_VERSIONS}; then
+ ewarn "In v2, the initramfs filename has changed to initramfs*.img, to match"
+ ewarn "the default names used by dracut and genkernel-4. If your bootloader"
+ ewarn "config uses the verbatim filename, please update it."
+ fi
+}