summaryrefslogtreecommitdiff
path: root/sys-kernel/gentoo-sources/gentoo-sources-6.6.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-02 23:42:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-02 23:42:06 +0000
commitc8042d10e135808d5f2b48867bc291e00664b99b (patch)
tree7ff539056fa93b5d71b38241122ac9d6566cf672 /sys-kernel/gentoo-sources/gentoo-sources-6.6.20.ebuild
parent7c58ecff5764af03b4c65f4115d7b9474e3a5717 (diff)
gentoo auto-resync : 02:03:2024 - 23:42:06
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-6.6.20.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-6.6.20.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-6.6.20.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-6.6.20.ebuild
new file mode 100644
index 000000000000..bbb304dc01b2
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-6.6.20.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="26"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}