summaryrefslogtreecommitdiff
path: root/sys-kernel/gentoo-sources/gentoo-sources-6.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-26 13:32:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-26 13:32:27 +0100
commite41409e9c4ccf0cd1b45b81f9d2370d13326cfc2 (patch)
tree5901bb51037c12595c29b9a697dba99dbc95c5e9 /sys-kernel/gentoo-sources/gentoo-sources-6.4.0.ebuild
parentf935e23b9515ca0a4f338a1a57ff12e21b0c6b0a (diff)
gentoo auto-resync : 26:06:2023 - 13:32:27
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-6.4.0.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-6.4.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-6.4.0.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-6.4.0.ebuild
new file mode 100644
index 000000000000..dd8c3136ff6d
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-6.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}