summaryrefslogtreecommitdiff
path: root/sys-kernel/gentoo-sources/gentoo-sources-6.1.51.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-02 16:16:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-02 16:16:36 +0100
commite5206efa6e88d32e3819685adee35c49124ccf0e (patch)
treeeb8101c8b97f1aa253537d4ea141dc5bf9c9902b /sys-kernel/gentoo-sources/gentoo-sources-6.1.51.ebuild
parent15bd3dfb22c7ba23dad0823e326dbcb8bb31b892 (diff)
gentoo auto-resync : 02:09:2023 - 16:16:36
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-6.1.51.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-6.1.51.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-6.1.51.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-6.1.51.ebuild
new file mode 100644
index 000000000000..a065335809a0
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-6.1.51.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="57"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}