summaryrefslogtreecommitdiff
path: root/sys-kernel/gentoo-sources/gentoo-sources-5.15.95.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-22 20:29:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-22 20:29:22 +0000
commit71fb24e4cc15fe73651423df81c5e6a79fa8c142 (patch)
tree962fbc79d3fbda0c4123d5119df5e728d4d7b18c /sys-kernel/gentoo-sources/gentoo-sources-5.15.95.ebuild
parentaae71b4d8e684ca22d28ef0f1da0989e7bf6468d (diff)
gentoo auto-resync : 22:02:2023 - 20:29:22
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-5.15.95.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-5.15.95.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-5.15.95.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-5.15.95.ebuild
new file mode 100644
index 000000000000..9fecfef1599b
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-5.15.95.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="99"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}