summaryrefslogtreecommitdiff
path: root/sys-kernel/gentoo-sources/gentoo-sources-5.15.152.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-16 00:48:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-16 00:48:13 +0000
commitd522d1ab80efc308821a88512ab6d40850d54cb0 (patch)
tree07dbebf1127598219fef59725122d71fd610bc30 /sys-kernel/gentoo-sources/gentoo-sources-5.15.152.ebuild
parenta4eda25bf0f72d757244b128657832bc4da28375 (diff)
gentoo auto-resync : 16:03:2024 - 00:48:12
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-5.15.152.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-5.15.152.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-5.15.152.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-5.15.152.ebuild
new file mode 100644
index 000000000000..ee9ee0c8b718
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-5.15.152.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="161"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}