summaryrefslogtreecommitdiff
path: root/sys-kernel/gentoo-sources/gentoo-sources-4.14.319.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-21 19:19:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-21 19:19:56 +0100
commitc0bcbed1a8a833beeae3ab7541dc9f460ab7cfce (patch)
treecfbec5f5e8ea4ab52c4d7bc2966c1ab960fe64ba /sys-kernel/gentoo-sources/gentoo-sources-4.14.319.ebuild
parentb02a2ac044a27eeef2c52b57308a8591b07448fa (diff)
gentoo auto-resync : 21:06:2023 - 19:19:56
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-4.14.319.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.14.319.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.14.319.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.14.319.ebuild
new file mode 100644
index 000000000000..35d02a74b878
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.14.319.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="330"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}