summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-12 17:42:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-12 17:42:09 +0100
commit12d78242dec4f785d0a0bfb1c00eee2d8996c53b (patch)
tree0e7146574ec8dc5e4e1ebe328c68a50a48f170ca /sys-fs
parent6e0dec7ba4f6c5793a3d0b85952efa7ec57afa65 (diff)
gentoo resync : 12.10.2017 (fix rsync script)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/avfs/avfs-1.0.1.ebuild60
-rw-r--r--sys-fs/avfs/avfs-1.0.2.ebuild60
-rw-r--r--sys-fs/avfs/avfs-1.0.3.ebuild60
3 files changed, 0 insertions, 180 deletions
diff --git a/sys-fs/avfs/avfs-1.0.1.ebuild b/sys-fs/avfs/avfs-1.0.1.ebuild
deleted file mode 100644
index c5aa5af0bb49..000000000000
--- a/sys-fs/avfs/avfs-1.0.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils
-
-DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed files"
-HOMEPAGE="https://sourceforge.net/projects/avf"
-SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ppc ppc64 x86"
-IUSE="static-libs +lzma"
-
-RDEPEND=">=sys-fs/fuse-2.4
- sys-libs/zlib
- app-arch/bzip2
- lzma? ( app-arch/xz-utils )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_configure() {
- econf \
- --enable-fuse \
- --enable-library \
- --enable-shared \
- --with-system-zlib \
- --with-system-bzlib \
- $(use_enable static-libs static) \
- $(use_with lzma xz)
-}
-
-src_install() {
- default
-
- # remove cruft
- rm "${D}"/usr/bin/{davpass,ftppass} || die
-
- # install docs
- dodoc doc/{api-overview,background,FORMAT,INSTALL.*,README.avfs-fuse}
- dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
-
- docinto scripts
- dodoc scripts/{avfscoda*,*pass}
-
- prune_libtool_files
-}
-
-pkg_postinst() {
- einfo "This version of AVFS includes FUSE support. It is user-based."
- einfo "To execute:"
- einfo "1) as user, mkdir ~/.avfs"
- einfo "2) make sure fuse is either compiled into the kernel OR"
- einfo " modprobe fuse or add to startup."
- einfo "3) run mountavfs"
- einfo "To unload daemon, type umountavfs"
- einfo
- einfo "READ the documentation! Enjoy :)"
-}
diff --git a/sys-fs/avfs/avfs-1.0.2.ebuild b/sys-fs/avfs/avfs-1.0.2.ebuild
deleted file mode 100644
index e48ad20ffdf6..000000000000
--- a/sys-fs/avfs/avfs-1.0.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils
-
-DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed files"
-HOMEPAGE="https://sourceforge.net/projects/avf"
-SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
-IUSE="static-libs +lzma"
-
-RDEPEND=">=sys-fs/fuse-2.4
- sys-libs/zlib
- app-arch/bzip2
- lzma? ( app-arch/xz-utils )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_configure() {
- econf \
- --enable-fuse \
- --enable-library \
- --enable-shared \
- --with-system-zlib \
- --with-system-bzlib \
- $(use_enable static-libs static) \
- $(use_with lzma xz)
-}
-
-src_install() {
- default
-
- # remove cruft
- rm "${D}"/usr/bin/{davpass,ftppass} || die
-
- # install docs
- dodoc doc/{api-overview,background,FORMAT,INSTALL.*,README.avfs-fuse}
- dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
-
- docinto scripts
- dodoc scripts/{avfscoda*,*pass}
-
- prune_libtool_files
-}
-
-pkg_postinst() {
- einfo "This version of AVFS includes FUSE support. It is user-based."
- einfo "To execute:"
- einfo "1) as user, mkdir ~/.avfs"
- einfo "2) make sure fuse is either compiled into the kernel OR"
- einfo " modprobe fuse or add to startup."
- einfo "3) run mountavfs"
- einfo "To unload daemon, type umountavfs"
- einfo
- einfo "READ the documentation! Enjoy :)"
-}
diff --git a/sys-fs/avfs/avfs-1.0.3.ebuild b/sys-fs/avfs/avfs-1.0.3.ebuild
deleted file mode 100644
index ac3655b36020..000000000000
--- a/sys-fs/avfs/avfs-1.0.3.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils
-
-DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed files"
-HOMEPAGE="https://sourceforge.net/projects/avf"
-SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
-IUSE="static-libs +lzma"
-
-RDEPEND=">=sys-fs/fuse-2.4
- sys-libs/zlib
- app-arch/bzip2
- lzma? ( app-arch/xz-utils )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_configure() {
- econf \
- --enable-fuse \
- --enable-library \
- --enable-shared \
- --with-system-zlib \
- --with-system-bzlib \
- $(use_enable static-libs static) \
- $(use_with lzma xz)
-}
-
-src_install() {
- default
-
- # remove cruft
- rm "${D}"/usr/bin/{davpass,ftppass} || die
-
- # install docs
- dodoc doc/{api-overview,background,FORMAT,INSTALL.*,README.avfs-fuse}
- dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
-
- docinto scripts
- dodoc scripts/{avfscoda*,*pass}
-
- prune_libtool_files
-}
-
-pkg_postinst() {
- einfo "This version of AVFS includes FUSE support. It is user-based."
- einfo "To execute:"
- einfo "1) as user, mkdir ~/.avfs"
- einfo "2) make sure fuse is either compiled into the kernel OR"
- einfo " modprobe fuse or add to startup."
- einfo "3) run mountavfs"
- einfo "To unload daemon, type umountavfs"
- einfo
- einfo "READ the documentation! Enjoy :)"
-}