summaryrefslogtreecommitdiff
path: root/sys-fs/xwmfs/xwmfs-0.85.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /sys-fs/xwmfs/xwmfs-0.85.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'sys-fs/xwmfs/xwmfs-0.85.ebuild')
-rw-r--r--sys-fs/xwmfs/xwmfs-0.85.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-fs/xwmfs/xwmfs-0.85.ebuild b/sys-fs/xwmfs/xwmfs-0.85.ebuild
new file mode 100644
index 000000000000..1f23a8953190
--- /dev/null
+++ b/sys-fs/xwmfs/xwmfs-0.85.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="FUSE-based X11 Window-Manager file system"
+HOMEPAGE="https://github.com/gerstner-hub/xwmfs"
+SRC_URI="https://github.com/gerstner-hub/${PN}/releases/download/v${PV}/${P}-dist.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+
+RDEPEND="
+ sys-fs/fuse:0=
+ >=x11-libs/libX11-1.6.5"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_test() {
+ # unset display to avoid testing errors, tests rely on X11 and a window
+ # manager environment
+ unset DISPLAY
+
+ default
+}