summaryrefslogtreecommitdiff
path: root/sys-fs/xwmfs/xwmfs-0.83.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /sys-fs/xwmfs/xwmfs-0.83.ebuild
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'sys-fs/xwmfs/xwmfs-0.83.ebuild')
-rw-r--r--sys-fs/xwmfs/xwmfs-0.83.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-fs/xwmfs/xwmfs-0.83.ebuild b/sys-fs/xwmfs/xwmfs-0.83.ebuild
new file mode 100644
index 000000000000..b64c09fda99b
--- /dev/null
+++ b/sys-fs/xwmfs/xwmfs-0.83.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="FUSE-based X11 Window-Manager file system"
+HOMEPAGE="https://github.com/gerstner-hub/xwmfs"
+SRC_URI="https://github.com/gerstner-hub/${PN}/releases/download/v${PV}/${P}-dist.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+
+RDEPEND="
+ sys-fs/fuse:0=
+ >=x11-libs/libX11-1.6.5"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_test() {
+ # unset display to avoid testing errors, tests rely on X11 and a window
+ # manager environment
+ unset DISPLAY
+
+ default
+}