summaryrefslogtreecommitdiff
path: root/sys-fs/xfsdump
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /sys-fs/xfsdump
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'sys-fs/xfsdump')
-rw-r--r--sys-fs/xfsdump/Manifest1
-rw-r--r--sys-fs/xfsdump/xfsdump-3.1.9-r1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-fs/xfsdump/Manifest b/sys-fs/xfsdump/Manifest
index fa0903de1bd5..b0c210c97f07 100644
--- a/sys-fs/xfsdump/Manifest
+++ b/sys-fs/xfsdump/Manifest
@@ -4,5 +4,6 @@ AUX xfsdump-3.1.9-no-symlink.patch 1027 BLAKE2B 35e0a308e9c368448305361e1632a229
AUX xfsdump-3.1.9-prompt-overflow.patch 329 BLAKE2B 58bada935969c61fe9a161e810c6402642a87d0803076c89f1cecf5367037f96ff234d3231c49fa8b450810b21f60ac391bd631400e30738b9b11d3000158bd7 SHA512 dae03fd09ac45c8a974cf1818625cbb07c1bd7c88b28613f855d0a5878c1bf3bcb071c6f8ebd46627b83fd482ff4847a33f8a54f1de5be7595025df9f22d2fdf
AUX xfsdump-3.1.9-skip-inventory-debian-subfolder.patch 468 BLAKE2B 81cf0af8cef61efa4dff6e230b71c0db65c3e7d93fd252035b6b5bf14afe28e65eccaef22bc3fc4419d196b0cca1428bc1697233efcc4f28aa138beaf3a5ccbf SHA512 c94af1c52c95a7617586b64a8936cdbfbd3a264c9580fabc3e1e7d3d5c37ca368b97f730baef2330e796ef7459561fa37b03280601aaa3b79eb2f90d9af5170d
DIST xfsdump-3.1.9.tar.xz 600348 BLAKE2B 9e833acaacd3ad581b4f23731d7d613fcffa3d518f43638cddbc7da7015e582cb9415e00616e5e8586836831b6d5877fa83e8a5fd931fd454731bf2af7072095 SHA512 e8f9811d16fc06ab49fe2c109de0546c989575eca6e68b579c6d219a745f935952020069f58b357c5c87b944c5097ca2894466d328d09f06beb8a55880142351
+EBUILD xfsdump-3.1.9-r1.ebuild 1615 BLAKE2B cdec8971db53d7745a1ea77478b3ee266f48a5875f8921e19da04adde7f54a27471f8bcd745ff1801b9cca8f7264e560b30b9e4e388129e100fec0631141875d SHA512 24a8d2b84525bdca75217b903ec884693d7923c2f09a3e64e0d1e2ca465626e4ef883acc05bc5d2f31dd2305dbcab1982c6102b43d9e419f748f86fea9f8d5c1
EBUILD xfsdump-3.1.9.ebuild 1627 BLAKE2B a0a8dc7e37a915700699b5db970c755a84fc679ffb327654bbb07592b297740a9fb945062442d439d026e15c82a56423ecfe61c02dea497e59af549e0aa7d83a SHA512 c4de8c287915cc9e6934b8fbafb9ae1ca44a9b8e5cfa81c09defbad9b60facb0fc0344dfc94b49dbceaf6a97e87529821a76e2465f5044c47a91b8d8929f59f7
MISC metadata.xml 253 BLAKE2B 295e9d6d93aaa12af413972e1590c67087801cc09c9aa6b59d4606c0f4106d1dacf2baa9858559083b4c6d91beeef218d0729e8593a33788958da6d2897e8ce2 SHA512 54a9069aeb4165d2dff3d473c8001bc51613aac9dff3f7f5e9971a9891a737a31511ffa11cbd523febe581ac1d9de2bdf2f40410f0c4239138f2ccca3ef15555
diff --git a/sys-fs/xfsdump/xfsdump-3.1.9-r1.ebuild b/sys-fs/xfsdump/xfsdump-3.1.9-r1.ebuild
new file mode 100644
index 000000000000..aafb02db2752
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-3.1.9-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="https://xfs.wiki.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE="ncurses nls"
+
+RDEPEND="
+ >=sys-apps/attr-2.4.19
+ sys-apps/util-linux
+ sys-fs/e2fsprogs
+ >=sys-fs/xfsprogs-3.2.0
+ ncurses? ( sys-libs/ncurses:0= )
+"
+DEPEND="${RDEPEND}
+ nls? (
+ sys-devel/gettext
+ elibc_uclibc? ( dev-libs/libintl )
+ )
+"
+BDEPEND="ncurses? ( virtual/pkgconfig )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.9-prompt-overflow.patch #335115
+ "${FILESDIR}"/${PN}-3.1.9-no-symlink.patch #311881
+ "${FILESDIR}"/${PN}-3.1.6-linguas.patch #561664
+ "${FILESDIR}"/${PN}-3.1.9-fix-docs.patch
+ "${FILESDIR}"/${PN}-3.1.9-skip-inventory-debian-subfolder.patch
+)
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die
+
+ sed -i \
+ -e "s:enable_curses=[a-z]*:enable_curses=$(usex ncurses):" \
+ -e "s:libcurses=\"[^\"]*\":libcurses='$(use ncurses && $(tc-getPKG_CONFIG) --libs ncurses)':" \
+ configure || die #605852
+
+ default
+}
+
+src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ local myeconfargs=(
+ $(use_enable nls gettext)
+ --libdir="${EPREFIX}/$(get_libdir)"
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)"
+ --sbindir="${EPREFIX}/sbin"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # enable verbose build
+ emake V=1
+}