summaryrefslogtreecommitdiff
path: root/sys-fs/vhba/vhba-20211218-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-20 02:17:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-20 02:17:30 +0000
commit8dd17625671faf6a47abf31d4c96a1e20d764ba5 (patch)
tree6dd5062cd293d1c2fc5af1f89cd548c7b3a62f3c /sys-fs/vhba/vhba-20211218-r1.ebuild
parentd4725f7e03f4d243d29d408f4b9de39459e00d4c (diff)
gentoo auto-resync : 20:02:2023 - 02:17:29
Diffstat (limited to 'sys-fs/vhba/vhba-20211218-r1.ebuild')
-rw-r--r--sys-fs/vhba/vhba-20211218-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-fs/vhba/vhba-20211218-r1.ebuild b/sys-fs/vhba/vhba-20211218-r1.ebuild
new file mode 100644
index 000000000000..b22eb7530805
--- /dev/null
+++ b/sys-fs/vhba/vhba-20211218-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod udev
+
+MY_P=vhba-module-${PV}
+DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
+HOMEPAGE="https://cdemu.sourceforge.io/"
+SRC_URI="https://download.sourceforge.net/cdemu/vhba-module/${MY_P}.tar.xz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ virtual/udev
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+MODULE_NAMES="vhba(block:${S})"
+BUILD_TARGETS=modules
+
+pkg_setup() {
+ CONFIG_CHECK="~BLK_DEV_SR ~CHR_DEV_SG"
+ check_extra_config
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR}"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ # Avoid -Werror problems
+ sed -i -e '/ccflags/s/-Werror/-Wall/' Makefile || die "sed failed"
+ eapply_user
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog README
+ linux-mod_src_install
+
+ einfo "Generating udev rules ..."
+ udev_newrules - 69-vhba.rules <<-EOF
+ # do not edit this file, it will be overwritten on update
+ #
+ KERNEL=="vhba_ctl", SUBSYSTEM=="misc", TAG+="uaccess"
+ EOF
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}