summaryrefslogtreecommitdiff
path: root/sys-fs/ubi_reader/ubi_reader-0.8.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
commit1c33e521c460dc40899ce7bc919602b842ce27e2 (patch)
tree580eefad4cce1e883e7504b93352a9029b53036d /sys-fs/ubi_reader/ubi_reader-0.8.5-r1.ebuild
parent65e4244e411c4f65f55f2aa91f39e228f4c0680b (diff)
gentoo auto-resync : 05:03:2023 - 23:52:45
Diffstat (limited to 'sys-fs/ubi_reader/ubi_reader-0.8.5-r1.ebuild')
-rw-r--r--sys-fs/ubi_reader/ubi_reader-0.8.5-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sys-fs/ubi_reader/ubi_reader-0.8.5-r1.ebuild b/sys-fs/ubi_reader/ubi_reader-0.8.5-r1.ebuild
new file mode 100644
index 000000000000..ea7eb78871bb
--- /dev/null
+++ b/sys-fs/ubi_reader/ubi_reader-0.8.5-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+MY_PN="${PN/_/-}"
+DESCRIPTION="Collection of Python scripts for extracting data from UBI and UBIFS images"
+HOMEPAGE="https://github.com/jrspruitt/ubi_reader"
+SRC_URI="https://github.com/jrspruitt/ubi_reader/archive/refs/tags/v${PV}-master.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}-master"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/python-lzo[${PYTHON_USEDEP}]"