summaryrefslogtreecommitdiff
path: root/sys-fs/reiserfsprogs/reiserfsprogs-3.6.25.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/reiserfsprogs/reiserfsprogs-3.6.25.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/reiserfsprogs/reiserfsprogs-3.6.25.ebuild')
-rw-r--r--sys-fs/reiserfsprogs/reiserfsprogs-3.6.25.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.25.ebuild b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.25.ebuild
new file mode 100644
index 000000000000..cd95b4756b1f
--- /dev/null
+++ b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.25.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Reiserfs Utilities"
+HOMEPAGE="https://www.kernel.org/pub/linux/utils/fs/reiserfs/"
+SRC_URI="mirror://kernel/linux/utils/fs/reiserfs/${P}.tar.xz
+ mirror://kernel/linux/kernel/people/jeffm/${PN}/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ia64 ~mips ppc ppc64 -sparc x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.6.25-no_acl.patch"
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
+
+src_configure() {
+ append-flags -std=gnu89 #427300
+ local myeconfargs=(
+ --bindir="${EPREFIX}/bin"
+ --libdir="${EPREFIX}/$(get_libdir)"
+ --sbindir="${EPREFIX}/sbin"
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodir /usr/$(get_libdir)
+ mv "${D}"/$(get_libdir)/pkgconfig "${D}"/usr/$(get_libdir) || die
+
+ if use static-libs ; then
+ mv "${D}"/$(get_libdir)/*a "${D}"/usr/$(get_libdir) || die
+ gen_usr_ldscript libreiserfscore.so
+ else
+ find "${D}" -type f \( -name "*.a" -o -name "*.la" \) -delete
+ fi
+}