summaryrefslogtreecommitdiff
path: root/sys-fs/rar2fs/rar2fs-1.27.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /sys-fs/rar2fs/rar2fs-1.27.2-r1.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'sys-fs/rar2fs/rar2fs-1.27.2-r1.ebuild')
-rw-r--r--sys-fs/rar2fs/rar2fs-1.27.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-fs/rar2fs/rar2fs-1.27.2-r1.ebuild b/sys-fs/rar2fs/rar2fs-1.27.2-r1.ebuild
new file mode 100644
index 000000000000..3860f0c11dbf
--- /dev/null
+++ b/sys-fs/rar2fs/rar2fs-1.27.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A FUSE based filesystem that can mount one or multiple RAR archive(s)"
+HOMEPAGE="https://hasse69.github.io/rar2fs/ https://github.com/hasse69/rar2fs"
+SRC_URI="https://github.com/hasse69/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Note that upstream unrar sometimes breaks ABI without updating the SONAME
+# version so try rebuilding rar2fs if it doesn't work following an unrar
+# upgrade.
+RDEPEND=">=app-arch/unrar-5:=
+ sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ export USER_CFLAGS="${CFLAGS}"
+
+ econf \
+ --with-unrar=/usr/include/libunrar \
+ --disable-static-unrar \
+ $(use_enable debug)
+}