summaryrefslogtreecommitdiff
path: root/sys-fs/pysize/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/pysize/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/pysize/files')
-rw-r--r--sys-fs/pysize/files/0.2-setuptools-automagic.patch12
-rw-r--r--sys-fs/pysize/files/psyco-0.2-automagic.patch20
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-fs/pysize/files/0.2-setuptools-automagic.patch b/sys-fs/pysize/files/0.2-setuptools-automagic.patch
new file mode 100644
index 000000000000..3e27c889f1a5
--- /dev/null
+++ b/sys-fs/pysize/files/0.2-setuptools-automagic.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 5550188..123d22c 100755
+--- a/setup.py
++++ b/setup.py
+@@ -2,7 +2,6 @@
+
+ import sys
+
+-sys.path.append('setuptools-0.7a1dev_r53614-py2.4.egg')
+ from setuptools import setup, find_packages
+ from pysize.version import VERSION
+
diff --git a/sys-fs/pysize/files/psyco-0.2-automagic.patch b/sys-fs/pysize/files/psyco-0.2-automagic.patch
new file mode 100644
index 000000000000..696f81fa4feb
--- /dev/null
+++ b/sys-fs/pysize/files/psyco-0.2-automagic.patch
@@ -0,0 +1,20 @@
+--- pysize/main.py 2007-03-11 16:09:53.000000000 +0100
++++ pysize/main.py.new 2009-01-02 00:08:43.384827054 +0100
+@@ -69,17 +69,8 @@
+ stats.print_stats(40)
+ os.remove(prof_file)
+
+-def _try_psyco():
+- try:
+- # Try to use psyco if available
+- import psyco
+- psyco.full()
+- except ImportError:
+- pass
+-
+ def main():
+ install_sigquit_traceback()
+- _try_psyco()
+ locale.setlocale(locale.LC_ALL, '')
+ usage = '%s [OPTIONS] [DIRECTORIES...]' % (sys.argv[0])
+ parser = optparse.OptionParser(usage=usage, version='pysize ' + VERSION)