summaryrefslogtreecommitdiff
path: root/sys-fs/ncdu/ncdu-2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-29 16:01:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-29 16:01:29 +0100
commit9cd7e710ac676c1a318d09e665ca3558bb5c5323 (patch)
treee9be71b324835aa5fe0d86769dc47ba880e3313b /sys-fs/ncdu/ncdu-2.2.ebuild
parent8ba401288d74259a5fd8e9de5241dd57a0a73b1f (diff)
gentoo auto-resync : 29:10:2022 - 16:01:29
Diffstat (limited to 'sys-fs/ncdu/ncdu-2.2.ebuild')
-rw-r--r--sys-fs/ncdu/ncdu-2.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-fs/ncdu/ncdu-2.2.ebuild b/sys-fs/ncdu/ncdu-2.2.ebuild
new file mode 100644
index 000000000000..b1f2a22f2abc
--- /dev/null
+++ b/sys-fs/ncdu/ncdu-2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="NCurses Disk Usage"
+HOMEPAGE="https://dev.yorhel.nl/ncdu/"
+SRC_URI="https://dev.yorhel.nl/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="sys-libs/ncurses:=[unicode(+)]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ || ( ~dev-lang/zig-0.9.1 ~dev-lang/zig-bin-0.9.1 )
+ virtual/pkgconfig
+"
+
+# see https://github.com/ziglang/zig/issues/3382
+# For now, Zig doesn't support CFLAGS/LDFLAGS/etc.
+QA_FLAGS_IGNORED="usr/bin/ncdu"
+
+src_test() {
+ zig build test || die "Tests failed"
+}
+
+src_install() {
+ emake PREFIX="${ED}"/usr install
+
+ dodoc README.md ChangeLog
+}