summaryrefslogtreecommitdiff
path: root/sys-fs/multipath-tools/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /sys-fs/multipath-tools/files
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'sys-fs/multipath-tools/files')
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.8.3-fix-gcc-10-compatibility.patch11
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.8.3-json-c-0.14.patch28
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.8.4-parallel_make_fix.patch85
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.8.4-respect-flags.patch19
4 files changed, 143 insertions, 0 deletions
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.8.3-fix-gcc-10-compatibility.patch b/sys-fs/multipath-tools/files/multipath-tools-0.8.3-fix-gcc-10-compatibility.patch
new file mode 100644
index 000000000000..18ed8d65e0f9
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.8.3-fix-gcc-10-compatibility.patch
@@ -0,0 +1,11 @@
+--- a/libmultipath/structs.h
++++ b/libmultipath/structs.h
+@@ -106,7 +106,7 @@ enum yes_no_undef_states {
+ * _FIND_MULTIPATHS_F must have the same value as YNU_YES.
+ * Generate a compile time error if that isn't the case.
+ */
+-char ___error1___[-(_FIND_MULTIPATHS_F != YNU_YES)];
++extern char ___error1___[-(_FIND_MULTIPATHS_F != YNU_YES)];
+
+ #define find_multipaths_on(conf) \
+ (!!((conf)->find_multipaths & _FIND_MULTIPATHS_F))
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.8.3-json-c-0.14.patch b/sys-fs/multipath-tools/files/multipath-tools-0.8.3-json-c-0.14.patch
new file mode 100644
index 000000000000..34d02f7b5d7f
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.8.3-json-c-0.14.patch
@@ -0,0 +1,28 @@
+From 8438a9cd8d7ed88645fa8e6a8f19c0fd9ae872a7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
+Date: Mon, 13 Apr 2020 19:22:02 +0200
+Subject: [PATCH] Add support for upcoming json-c 0.14.0.
+
+TRUE/FALSE are not defined anymore. 1 and 0 are used instead.
+This is backwards compatible, as earlier versions of json-c are
+using the same integer values in their present definitions.
+---
+ libdmmp/libdmmp_private.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libdmmp/libdmmp_private.h b/libdmmp/libdmmp_private.h
+index ac85b63f..4378962b 100644
+--- a/libdmmp/libdmmp_private.h
++++ b/libdmmp/libdmmp_private.h
+@@ -82,7 +82,7 @@ static out_type func_name(struct dmmp_context *ctx, const char *var_name) { \
+ do { \
+ json_type j_type = json_type_null; \
+ json_object *j_obj_tmp = NULL; \
+- if (json_object_object_get_ex(j_obj, key, &j_obj_tmp) != TRUE) { \
++ if (json_object_object_get_ex(j_obj, key, &j_obj_tmp) != 1) { \
+ _error(ctx, "Invalid JSON output from multipathd IPC: " \
+ "key '%s' not found", key); \
+ rc = DMMP_ERR_IPC_ERROR; \
+--
+2.26.0
+
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.8.4-parallel_make_fix.patch b/sys-fs/multipath-tools/files/multipath-tools-0.8.4-parallel_make_fix.patch
new file mode 100644
index 000000000000..651cd04f59fd
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.8.4-parallel_make_fix.patch
@@ -0,0 +1,85 @@
+From 041472afebd1e621be1143f2bfb4c5650df171cc Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Mon, 11 May 2020 11:49:58 +0200
+Subject: [PATCH] multipath-tools: Fix parallel make issues
+
+build is broken like this (tested with -j16):
+
+ x86_64-pc-linux-gnu-gcc -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common -Wl,--as-needed -Wl,-z,relro -Wl,-z,now -shared -lpthread -ldevmapper -ldl -L../libmultipath -lmultipath -L../libmpathcmd -lmpathcmd -Wl,-soname=libmpathpersist.so.0 -o libmpathpersist.so.0 mpath_persist.o mpath_updatepr.o mpath_pr_ioctl.o
+ building defaults.o because of defaults.c
+ ...
+ /usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lmultipath
+ collect2: error: ld returned 1 exit status
+ make[1]: *** [Makefile:17: libmpathpersist.so.0] Error 1
+ make: *** [Makefile:29: libmpathpersist] Error 2
+ make: *** Waiting for unfinished jobs....
+
+install is broken like this:
+
+ install -m 755 libprio*.so /var/tmp/portage/sys-fs/multipath-tools-0.8.4/image/lib64/multipath
+ install -m 755 libcheckcciss_tur.so libcheckreadsector0.so libchecktur.so libcheckdirectio.so libcheckemc_clariion.so libcheckhp_sw.so libcheckrdac.so /var/tmp/portage/sys-fs/multipath-tools-0.8.4/image/lib64/multipath
+ ...
+ /usr/bin/install: target '/var/tmp/portage/sys-fs/multipath-tools-0.8.4/image/lib64/multipath' is not a directory
+ /usr/bin/install: target '/var/tmp/portage/sys-fs/multipath-tools-0.8.4/image/lib64/multipath' is not a directory
+ make[1]: *** [Makefile:28: install] Error 1
+ make[1]: *** [Makefile:38: install] Error 1
+---
+ Makefile | 3 ++-
+ libmultipath/checkers/Makefile | 1 +
+ libmultipath/foreign/Makefile | 1 +
+ libmultipath/prioritizers/Makefile | 1 +
+ 4 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 1dee3680..a9ade94f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -29,7 +29,8 @@ $(BUILDDIRS):
+ $(MAKE) -C $@
+
+ multipath multipathd mpathpersist: libmultipath
+-mpathpersist: libmpathpersist
++libmpathpersist: libmultipath
++mpathpersist: libmultipath libmpathpersist
+
+ $(BUILDDIRS.clean):
+ $(MAKE) -C ${@:.clean=} clean
+diff --git a/libmultipath/checkers/Makefile b/libmultipath/checkers/Makefile
+index 02caea64..f201ca4c 100644
+--- a/libmultipath/checkers/Makefile
++++ b/libmultipath/checkers/Makefile
+@@ -24,6 +24,7 @@ libcheck%.so: libsg.o %.o
+ $(CC) $(LDFLAGS) $(SHARED_FLAGS) -o $@ $^
+
+ install:
++ $(INSTALL_PROGRAM) -m 755 -d $(DESTDIR)$(libdir)
+ $(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(libdir)
+
+ uninstall:
+diff --git a/libmultipath/foreign/Makefile b/libmultipath/foreign/Makefile
+index fae58a0d..567deebd 100644
+--- a/libmultipath/foreign/Makefile
++++ b/libmultipath/foreign/Makefile
+@@ -14,6 +14,7 @@ libforeign-%.so: %.o
+ $(CC) $(LDFLAGS) $(SHARED_FLAGS) -o $@ $^
+
+ install:
++ $(INSTALL_PROGRAM) -m 755 -d $(DESTDIR)$(libdir)
+ $(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(libdir)
+
+ uninstall:
+diff --git a/libmultipath/prioritizers/Makefile b/libmultipath/prioritizers/Makefile
+index 9d0fe03c..b0b0b522 100644
+--- a/libmultipath/prioritizers/Makefile
++++ b/libmultipath/prioritizers/Makefile
+@@ -35,6 +35,7 @@ libprio%.so: %.o
+ $(CC) $(LDFLAGS) $(SHARED_FLAGS) -o $@ $^
+
+ install: $(LIBS)
++ $(INSTALL_PROGRAM) -m 755 -d $(DESTDIR)$(libdir)
+ $(INSTALL_PROGRAM) -m 755 libprio*.so $(DESTDIR)$(libdir)
+
+ uninstall:
+--
+2.26.2
+
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.8.4-respect-flags.patch b/sys-fs/multipath-tools/files/multipath-tools-0.8.4-respect-flags.patch
new file mode 100644
index 000000000000..5e5258405b4f
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.8.4-respect-flags.patch
@@ -0,0 +1,19 @@
+--- multipath-tools-0.8.4-d491591/Makefile.inc
++++ multipath-tools-0.8.4-d491591/Makefile.inc
+@@ -99,12 +99,13 @@
+ -Werror=cast-qual $(ERROR_DISCARDED_QUALIFIERS) \
+ $(STACKPROT) --param=ssp-buffer-size=4
+ CPPFLAGS := -Wp,-D_FORTIFY_SOURCE=2
+-CFLAGS := $(OPTFLAGS) -DBIN_DIR=\"$(bindir)\" -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\" \
+- -MMD -MP $(CFLAGS)
++CFLAGS ?= $(OPTFLAGS)
++CFLAGS += -DBIN_DIR=\"$(bindir)\" -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\" \
++ -MMD -MP
+ BIN_CFLAGS = -fPIE -DPIE
+ LIB_CFLAGS = -fPIC
+ SHARED_FLAGS = -shared
+-LDFLAGS = -Wl,-z,relro -Wl,-z,now
++LDFLAGS += -Wl,-z,relro -Wl,-z,now
+ BIN_LDFLAGS = -pie
+
+ # Check whether a function with name $1 has been declared in header file $2.