summaryrefslogtreecommitdiff
path: root/sys-fs/mtools/mtools-4.0.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/mtools/mtools-4.0.17.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/mtools/mtools-4.0.17.ebuild')
-rw-r--r--sys-fs/mtools/mtools-4.0.17.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-fs/mtools/mtools-4.0.17.ebuild b/sys-fs/mtools/mtools-4.0.17.ebuild
new file mode 100644
index 000000000000..126e15a993df
--- /dev/null
+++ b/sys-fs/mtools/mtools-4.0.17.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+DESCRIPTION="utilities to access MS-DOS disks from Unix without mounting them"
+HOMEPAGE="http://mtools.linux.lu/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X"
+
+DEPEND="
+ X? (
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXt
+ )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Don't throw errors on existing directories
+ sed -i -e "s:mkdir:mkdir -p:" mkinstalldirs || die
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/mtools \
+ $(use_with X x)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README* Release.notes
+
+ insinto /etc/mtools
+ doins mtools.conf
+ # default is fine
+ sed -i -e '/^SAMPLE FILE$/s:^:#:' "${D}"/etc/mtools/mtools.conf || die
+}