summaryrefslogtreecommitdiff
path: root/sys-fs/lvm2/lvm2-2.03.22-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-16 22:04:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-16 22:04:19 +0100
commitaccc284898c2b08d44aca3a4207c0e1c9fac05f5 (patch)
treee657eeb464e8448e3c061045531567b462a53a63 /sys-fs/lvm2/lvm2-2.03.22-r2.ebuild
parent7f1592d914f244f1c2ab9e4bf84c003131f6d3b8 (diff)
gentoo auto-resync : 16:10:2023 - 22:04:19
Diffstat (limited to 'sys-fs/lvm2/lvm2-2.03.22-r2.ebuild')
-rw-r--r--sys-fs/lvm2/lvm2-2.03.22-r2.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/sys-fs/lvm2/lvm2-2.03.22-r2.ebuild b/sys-fs/lvm2/lvm2-2.03.22-r2.ebuild
index cac7188abf10..ba546b95e777 100644
--- a/sys-fs/lvm2/lvm2-2.03.22-r2.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.22-r2.ebuild
@@ -194,17 +194,17 @@ src_test() {
}
src_install() {
- local INSTALL_TARGETS=(
- # full LVM2
- $(usev lvm "install install_tmpfiles_configuration")
- # install systemd related files only when requested, bug #522430
- $(usev $(usex lvm systemd lvm) "SYSTEMD_GENERATOR_DIR=$(systemd_get_systemgeneratordir) \
- install_systemd_units install_systemd_generators")
-
- # install dm unconditionally
- install_device-mapper
- )
- emake V=1 DESTDIR="${D}" "${INSTALL_TARGETS[@]}"
+ local targets=()
+ if use lvm; then
+ targets+=( install install_tmpfiles_configuration )
+ if use systemd; then
+ # install systemd related files only when requested, bug #522430
+ targets+=( install_systemd_units )
+ fi
+ else
+ targets+=( install_device-mapper )
+ fi
+ emake V=1 DESTDIR="${D}" "${targets[@]}"
newinitd "${FILESDIR}"/device-mapper.rc-r3 device-mapper
newconfd "${FILESDIR}"/device-mapper.conf-r4 device-mapper