summaryrefslogtreecommitdiff
path: root/sys-fs/jfsutils/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sys-fs/jfsutils/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sys-fs/jfsutils/files')
-rw-r--r--sys-fs/jfsutils/files/jfsutils-1.1.15-check-for-ar.patch10
-rw-r--r--sys-fs/jfsutils/files/jfsutils-1.1.15-format-security-errors.patch40
-rw-r--r--sys-fs/jfsutils/files/jfsutils-1.1.15-gcc10.patch71
3 files changed, 121 insertions, 0 deletions
diff --git a/sys-fs/jfsutils/files/jfsutils-1.1.15-check-for-ar.patch b/sys-fs/jfsutils/files/jfsutils-1.1.15-check-for-ar.patch
new file mode 100644
index 000000000000..6469e7d82d22
--- /dev/null
+++ b/sys-fs/jfsutils/files/jfsutils-1.1.15-check-for-ar.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -9,6 +9,7 @@ dnl Don't include maintainer make-rules by default
+ AM_MAINTAINER_MODE
+
+ dnl Checks for programs.
++AM_PROG_AR
+ AC_PROG_AWK
+ AC_PROG_CC
+ AC_PROG_INSTALL
diff --git a/sys-fs/jfsutils/files/jfsutils-1.1.15-format-security-errors.patch b/sys-fs/jfsutils/files/jfsutils-1.1.15-format-security-errors.patch
new file mode 100644
index 000000000000..f66b9e0d46df
--- /dev/null
+++ b/sys-fs/jfsutils/files/jfsutils-1.1.15-format-security-errors.patch
@@ -0,0 +1,40 @@
+Origin: https://sources.debian.org/patches/jfsutils/1.1.15-5/format-security-errors.patch/
+
+--- a/fscklog/display.c
++++ b/fscklog/display.c
+@@ -182,7 +182,7 @@ void dump_service_log()
+ } else {
+ /* the record looks ok */
+ msg_txt = &log_entry[log_entry_pos];
+- printf(msg_txt);
++ printf("%s", msg_txt);
+ /*
+ * set up for the next record
+ */
+--- a/fscklog/fscklog.c
++++ b/fscklog/fscklog.c
+@@ -252,8 +252,8 @@ int v_send_msg(int msg_num, const char *file_name, int line_number, ...) {
+
+ sprintf(debug_detail, " [%s:%d]\n", basename(file_name), line_number);
+
+- printf(msg_string);
+- printf(debug_detail);
++ printf("%s", msg_string);
++ printf("%s", debug_detail);
+
+ return 0;
+ }
+--- a/logdump/helpers.c
++++ b/logdump/helpers.c
+@@ -95,8 +95,8 @@ int v_fsck_send_msg(int msg_num, const char *file_name, int line_number, ...) {
+
+ sprintf(debug_detail, " [%s:%d]\n", file_name, line_number);
+
+- printf(msg_string);
+- printf(debug_detail);
++ printf("%s", msg_string);
++ printf("%s", debug_detail);
+
+ return 0;
+ }
+
diff --git a/sys-fs/jfsutils/files/jfsutils-1.1.15-gcc10.patch b/sys-fs/jfsutils/files/jfsutils-1.1.15-gcc10.patch
new file mode 100644
index 000000000000..72160e8b4fae
--- /dev/null
+++ b/sys-fs/jfsutils/files/jfsutils-1.1.15-gcc10.patch
@@ -0,0 +1,71 @@
+Fix building with GCC 10
+
+Origin: https://sources.debian.org/patches/jfsutils/1.1.15-5/gcc10_fix-1.patch/
+
+--- jfsutils-1.1.15.old/fscklog/display.c
++++ jfsutils-1.1.15.new/fscklog/display.c
+@@ -54,7 +54,7 @@
+ * output: fsck extracted service log I/O buffer
+ *
+ */
+-char xchklog_buffer[XCHKLOG_BUFSIZE];
++static char xchklog_buffer[XCHKLOG_BUFSIZE];
+
+ /* + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
+ *
+--- jfsutils-1.1.15.old/libfs/logredo.c
++++ jfsutils-1.1.15.new/libfs/logredo.c
+@@ -87,9 +87,9 @@
+ * S T U F F F O R T H E L O G
+ *
+ */
+-struct logsuper logsup; /* log super block */
+-int32_t numdoblk; /* number of do blocks used */
+-int32_t numnodofile; /* number of nodo file blocks used */
++static struct logsuper logsup; /* log super block */
++static int32_t numdoblk; /* number of do blocks used */
++static int32_t numnodofile; /* number of nodo file blocks used */
+ int32_t numExtDtPg = 0; /* number of extended dtpage blocks used */
+
+ /*
+@@ -129,7 +129,7 @@
+ */
+
+ /* buffer header table */
+-struct bufhdr {
++static struct bufhdr {
+ int16_t next; /* 2: next on free/lru list */
+ int16_t prev; /* 2: previous on free/lru list */
+ int16_t hnext; /* 2: next on hash chain */
+@@ -142,7 +142,7 @@
+ } bufhdr[NBUFPOOL]; /* (24) */
+
+ /* buffer table */
+-struct bufpool {
++static struct bufpool {
+ char bytes[PSIZE];
+ } buffer[NBUFPOOL - 1];
+
+@@ -151,15 +151,16 @@
+ *
+ * log has its own 4 page buffer pool.
+ */
+-uint8_t afterdata[LOGPSIZE * 2]; /* buffer to read in redopage data */
++static uint8_t afterdata[LOGPSIZE * 2]; /* buffer to read in redopage data */
+
+ /*
+ * Miscellaneous
+ */
+-caddr_t prog; /* Program name */
+-int32_t mntcnt, bufsize;
+-char *mntinfo;
+-int32_t retcode; /* return code from logredo */
++static caddr_t prog; /* Program name */
++extern int32_t mntcnt;
++static int32_t bufsize;
++static char *mntinfo;
++static int32_t retcode; /* return code from logredo */
+ int end_of_transaction = 0;
+
+ /*
+