summaryrefslogtreecommitdiff
path: root/sys-fs/inotify-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-22 09:45:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-22 09:45:59 +0100
commit994ddedfa7bbe42aa3de4aa9ae3e58960bbdd94e (patch)
tree81561a97855bcb9d79784fb246dbdc9249d38274 /sys-fs/inotify-tools
parent102518876412b49c154cd247f5891927304dd8cc (diff)
gentoo auto-resync : 22:08:2023 - 09:45:59
Diffstat (limited to 'sys-fs/inotify-tools')
-rw-r--r--sys-fs/inotify-tools/Manifest2
-rw-r--r--sys-fs/inotify-tools/inotify-tools-4.23.8.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-fs/inotify-tools/Manifest b/sys-fs/inotify-tools/Manifest
index 91908d883709..3a7de0bb6ed5 100644
--- a/sys-fs/inotify-tools/Manifest
+++ b/sys-fs/inotify-tools/Manifest
@@ -1,4 +1,6 @@
AUX inotify-tools-3.22.6.0-musl.patch 6184 BLAKE2B 88e6ca44a4624dce3a1e92ebcb9d3da727a81420c2ee96b8075d66d3ce1d4353c7aee271be1b679a4b60e3ebf1f93c1d3f4011615e575157d0fc1caf1c21d83d SHA512 d5a7c1e788cc31b283d3a721d1baf95803ab9f83b0a2a67e84e3e7663600a59b2205248a8998859cbe5857f263ebee09c9299ee28076c70f859b8f68d0dc6318
DIST inotify-tools-3.22.6.0.tar.gz 92918 BLAKE2B 601d3ac6896e445d297a04498c63df4f81c59699ba2d5b2eee2e8c499332913ce2783d13c9906d577ff0b6d7ef91ca826d48b01674adeb3d3569dfc1fbc0df63 SHA512 cda445add4b9d80b70eff9189ed50d05f4b5593a755159d0354431166c6fe6fdb33f7bf37fd50bc09aad3ed0a6e3763b9c74f65e554400f2596b8d492f1d0a21
+DIST inotify-tools-4.23.8.0.tar.gz 93265 BLAKE2B 9aa6d33a090dd0ea055550c6540e4a7d4f0bcea0640d97c705dacecbddf388423ce217af9ac6df02bebfb0613f160d1860388c6f4e116d7c6cbc3fb42350a312 SHA512 0601f01aaf5be08fc5209710ea8c359b21d2dd6acd4ecfad79d86b287ea51b0b9201339d1bf6c3437e611ba3df760adec9ad7bb4083f13f93649e23d60fb64ed
EBUILD inotify-tools-3.22.6.0-r1.ebuild 881 BLAKE2B bed52561cb35fa207ff317fe49b3534b75b407b1c6629751b3b347867f7a504312a0f4f20c615c313142699342b0768b2676fc274378f483dd3ef90614b0b11b SHA512 b68378c11aee9299c24eebd33cac83e359366925cc5590b696d7a603d29bc7f5b4f1cc5cb7a7e332fa333b2de13b345df67af066533495e21ba92965daaf6889
+EBUILD inotify-tools-4.23.8.0.ebuild 847 BLAKE2B bce58c8bb38de00edfeb3805f24858e19250c5ad5d93b11469c9a852813bae7249a462a356f2e0d46e30843247c152c4314e5a910cced2776c0765c6fa5982d7 SHA512 02681e8aeb996b54e6571fea1d7fb1fd8f4e3e6f8d289ec031b3824585762ae9d4ac2c472abbd8b20a84c8fd51d739c0116e83347bcd77740fcca8b6ac906e88
MISC metadata.xml 590 BLAKE2B 6e50ca7a9b47cfe8bf97f73cb62c7e9f99d21c7687989a224136a38c075242f02386e14e5fc6d4e7216f9e44be32711005a2f366f2c26db02a900c6c5a852adf SHA512 a17f9f5e0b397c00f290e476ba9c40466149a40bb0bdbab9b75a726518ee413efc6fd64a13f2be5baf5f651c5a09a1f736c194122e5b3b81377d542b21cf925d
diff --git a/sys-fs/inotify-tools/inotify-tools-4.23.8.0.ebuild b/sys-fs/inotify-tools/inotify-tools-4.23.8.0.ebuild
new file mode 100644
index 000000000000..451fdbab4d0e
--- /dev/null
+++ b/sys-fs/inotify-tools/inotify-tools-4.23.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Set of command-line programs providing a simple interface to inotify"
+HOMEPAGE="https://github.com/inotify-tools/inotify-tools/"
+SRC_URI="
+ https://github.com/inotify-tools/inotify-tools/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~riscv ~sparc ~x86"
+IUSE="doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+
+ sed -i 's/ -Werror//' {,libinotifytools/}src/Makefile.am || die #745069
+
+ eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable doc doxygen)
+ )
+
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}