summaryrefslogtreecommitdiff
path: root/sys-fs/google-drive-ocamlfuse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-30 20:59:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-30 20:59:34 +0000
commit182063dd85a03f2086258946276c8967945ffe95 (patch)
tree94440d3476f11273b5072685640990ec95042468 /sys-fs/google-drive-ocamlfuse
parent268511f85b0606dd23fda1991345568dd3e1976b (diff)
gentoo auto-resync : 30:01:2023 - 20:59:33
Diffstat (limited to 'sys-fs/google-drive-ocamlfuse')
-rw-r--r--sys-fs/google-drive-ocamlfuse/Manifest2
-rw-r--r--sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.30.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-fs/google-drive-ocamlfuse/Manifest b/sys-fs/google-drive-ocamlfuse/Manifest
index d76e223ad76f..a1ca058d9656 100644
--- a/sys-fs/google-drive-ocamlfuse/Manifest
+++ b/sys-fs/google-drive-ocamlfuse/Manifest
@@ -1,3 +1,5 @@
DIST google-drive-ocamlfuse-0.7.29.gh.tar.gz 98832 BLAKE2B 7a959047abacc65379c2da0f590c6dba613cb7708dd56a7e029409d8791d76e6a0a164eea113b21a84b07bf522879401833431482f18d97865364eaee03dcb3b SHA512 562bca2e9019a999886052eb4b7f6554706c25be69670148c1938d3b30d742b03eafb6fba430c4762ba44713e291ec3b0cddabc1baaa6491740ddd3e77655fe9
+DIST google-drive-ocamlfuse-0.7.30.gh.tar.gz 98849 BLAKE2B 89ff486cc13d86b67ef4ceda769ff7e144d91cf8c4ce67a8d8fb011f7a26a2c21e802c71dbb8bda50b871de089cd6c70762bcb9640c841c84dcd8696b011ebee SHA512 4182ab3697b84afa983ea033f6de7f94a3482f2c9c9024c875feeee0ed196dbe33c97fa88a0a86c818b55f30eddd1f3d9ab674dd4a6df2a1f8abcfc793f4d4b3
EBUILD google-drive-ocamlfuse-0.7.29.ebuild 708 BLAKE2B 7d679289bb5c153a1074a4f006b65d347ba79596eff6a3173e880eebe1d750b0c37e22409caaa7a1b9e5d14fa0df1b6ed3bf1e6a146883edd942741f6fe3654c SHA512 bd20de3d367403c4f4ba61bd7658ec367c0c78ee9e9920613d093db84a7b360dcfab9a5ee76e6f09b84fe5d1d2ebb7c80c0064be37e83c197f038c6d64813b73
+EBUILD google-drive-ocamlfuse-0.7.30.ebuild 708 BLAKE2B 60e24319f253dc0f9aee410a2bd3097a8157517495e31087312141fb3cbe20f5caecbcd5979de99c1c24ccccdd2bf9a92fd5f4f2515756c3ff35d3b2831993b0 SHA512 1a58b85671cc68a643fa9f758bdbc9bc755277310b2bbd61ea43f05f2dfe3120bc5a2b4ed7613c17d4addcb3898c8b880da348427da1bdc47a04958f3bc21779
MISC metadata.xml 539 BLAKE2B c11bf57bc3c006108667297cfab65baae178521c9e84e979b578d7dc5170cd9c2d7a0b7c37469f663271045fef8e01c6a53b5240ff4a4a60b364fb83181e3a55 SHA512 6deded77c2a2657518cf903e1bc7738a9e66f302b7642e948aca3e357fb952435162f039f17e7b03d4bcc827901d87f3d6aaff2e968807ac8c67051b20b33ded
diff --git a/sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.30.ebuild b/sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.30.ebuild
new file mode 100644
index 000000000000..95bdbd6fd5f6
--- /dev/null
+++ b/sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.30.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune findlib
+
+DESCRIPTION="FUSE filesystem over Google Drive"
+HOMEPAGE="
+ https://github.com/astrada/google-drive-ocamlfuse
+ https://opam.ocaml.org/packages/google-drive-ocamlfuse/
+"
+SRC_URI="https://github.com/astrada/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RDEPEND="
+ >=dev-ml/gapi-ocaml-0.4.2:=
+ >=dev-ml/ocamlfuse-2.7.1:=
+ dev-ml/cryptokit:=
+ dev-ml/extlib:=
+ dev-ml/ocaml-sqlite3:=
+ >=dev-ml/tiny_httpd-0.6:=
+"
+DEPEND="
+ ${RDEPEND}
+ dev-ml/camlidl:=
+ test? ( dev-ml/ounit2 )
+"
+
+RESTRICT="!test? ( test )"