summaryrefslogtreecommitdiff
path: root/sys-fs/fuse-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /sys-fs/fuse-common
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'sys-fs/fuse-common')
-rw-r--r--sys-fs/fuse-common/Manifest5
-rw-r--r--sys-fs/fuse-common/files/fuse-fbsd.init23
-rw-r--r--sys-fs/fuse-common/files/fuse.init35
-rw-r--r--sys-fs/fuse-common/fuse-common-3.2.1.ebuild57
-rw-r--r--sys-fs/fuse-common/metadata.xml11
5 files changed, 131 insertions, 0 deletions
diff --git a/sys-fs/fuse-common/Manifest b/sys-fs/fuse-common/Manifest
new file mode 100644
index 000000000000..51c508129592
--- /dev/null
+++ b/sys-fs/fuse-common/Manifest
@@ -0,0 +1,5 @@
+AUX fuse-fbsd.init 468 BLAKE2B 3b84afb0e215064d4944808b87fdc29396e851042a83bb7c031586ec6da49f8f13c0593754ce6f6a92fc35ed4ce2f0f6d9c53089e08bf3ee960df577543bba49 SHA512 c8ae0e1932e34e2078bb8a1ab47c6d2d489f832f7adb118668624d3f0695ebf8b3ac2468a8db98579ef30078eac6989421aae7d7893e30a50e5c35d0a00ad6a9
+AUX fuse.init 757 BLAKE2B 802821596154d3dabae5c56367656d46a714c22a284cadf8ca78b2ca01a68fce8cefc37576cd26a14551452ff910a5317544e39b8fc4bddf74d80879fb7a0334 SHA512 7f6a503ef23cfa8b809c544375c2d83ad56525269b48ad1a7dff0ce36f4bf2f2a3fafed9dc70a71ff6281b261db5f01829e16c06f041921a5d8c8d715a04a8c1
+DIST fuse-3.2.1.tar.xz 1042772 BLAKE2B fe7dccc3b791a3b549815f5015a993c29d9481742a88b0291a03b39b95c0acb709969bdc0f6fbea5a48d0bb97bc362ad351b719d77a4f9f630825308f3fb1913 SHA512 edf08711fa02c40b9d3507c99e0b1bfd7208edc1494888c4e2bad92b621eb5c43c4cb31474d2d3bb1edaaf9cd876f3407cdb00a1bdcf61a0b74c876d3707518e
+EBUILD fuse-common-3.2.1.ebuild 1398 BLAKE2B 6948cf83261c2e47891b0990ecd6dc080d1a6a50a57c3fead02edfd68b54f260b458821be37beacf64d72d8fa318713c14bfbaeb580699d17e447e37f8895e72 SHA512 769b9ab430a4a62b25991c5f4cdf4facbdf974530a830d926405695fe7e8ca030f13347e98d46fc45d7795d6a3896befad55dd391719d5d4a9357dfeb3b4f109
+MISC metadata.xml 326 BLAKE2B e3a863aeff43218beaba67d6ca4692dad0b3854a706213db47880058af990e02655a30a55eb16dc3cbe546382f6e55989d0d8321eb115b8270a016d2c1c62ab8 SHA512 fcb872557acd0b8478fd8afe48c408a6dc08fda8eeba46f6db89470b6b3aa5d1287d4be9c5ec2aee80137901d4a1d943b61b22117849d283eafd3bd587c05eae
diff --git a/sys-fs/fuse-common/files/fuse-fbsd.init b/sys-fs/fuse-common/files/fuse-fbsd.init
new file mode 100644
index 000000000000..27d90cc867f3
--- /dev/null
+++ b/sys-fs/fuse-common/files/fuse-fbsd.init
@@ -0,0 +1,23 @@
+#!/sbin/openrc-run
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need localmount
+}
+
+start() {
+ ebegin "Starting fuse"
+ if ! kldstat -q -m fuse; then
+ kldload fuse >/dev/null 2>&1 || eerror $? "Error loading fuse module"
+ fi
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping fuse"
+ if kldstat -q -m fuse; then
+ kldunload fuse >/dev/null 2>&1 || eerror $? "Error unloading fuse module"
+ fi
+ eend ${?}
+}
diff --git a/sys-fs/fuse-common/files/fuse.init b/sys-fs/fuse-common/files/fuse.init
new file mode 100644
index 000000000000..6c99929c2266
--- /dev/null
+++ b/sys-fs/fuse-common/files/fuse.init
@@ -0,0 +1,35 @@
+#!/sbin/openrc-run
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+MOUNTPOINT=/sys/fs/fuse/connections
+
+depend() {
+ need localmount
+}
+
+start() {
+
+ ebegin "Starting fuse"
+ if ! grep -qw fuse /proc/filesystems; then
+ modprobe fuse >/dev/null 2>&1 || eerror $? "Error loading fuse module"
+ fi
+ if grep -qw fusectl /proc/filesystems && \
+ ! grep -qw $MOUNTPOINT /proc/mounts; then
+ mount -t fusectl none $MOUNTPOINT >/dev/null 2>&1 || \
+ eerror $? "Error mounting control filesystem"
+ fi
+ eend ${?}
+
+}
+
+stop() {
+
+ ebegin "Stopping fuse"
+ if grep -qw $MOUNTPOINT /proc/mounts; then
+ umount $MOUNTPOINT >/dev/null 2>&1 || \
+ eerror $? "Error unmounting control filesystem"
+ fi
+ eend ${?}
+
+}
diff --git a/sys-fs/fuse-common/fuse-common-3.2.1.ebuild b/sys-fs/fuse-common/fuse-common-3.2.1.ebuild
new file mode 100644
index 000000000000..15d8bd5e11fc
--- /dev/null
+++ b/sys-fs/fuse-common/fuse-common-3.2.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson udev flag-o-matic
+
+DESCRIPTION="Common files for multiple slots of sys-fs/fuse"
+HOMEPAGE="https://github.com/libfuse/libfuse"
+SRC_URI="https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="virtual/pkgconfig"
+RDEPEND="!<sys-fs/fuse-2.9.7-r1:0"
+
+S=${WORKDIR}/fuse-${PV}
+
+# tests run in sys-fs/fuse
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ # lto not supported yet -- https://github.com/libfuse/libfuse/issues/198
+ filter-flags -flto*
+}
+
+src_install() {
+ newsbin "${BUILD_DIR}"/util/mount.fuse3 mount.fuse
+ doman doc/mount.fuse.8
+
+ udev_newrules util/udev.rules 99-fuse.rules
+
+ if use kernel_linux ; then
+ newinitd "${FILESDIR}"/fuse.init fuse
+ elif use kernel_FreeBSD ; then
+ newinitd "${FILESDIR}"/fuse-fbsd.init fuse
+ else
+ die "We don't know what init code install for your kernel, please file a bug."
+ fi
+
+ dodir /etc
+ cat > "${ED}"/etc/fuse.conf <<-EOF
+ # Set the maximum number of FUSE mounts allowed to non-root users.
+ # The default is 1000.
+ #
+ #mount_max = 1000
+
+ # Allow non-root users to specify the 'allow_other' or 'allow_root'
+ # mount options.
+ #
+ #user_allow_other
+ EOF
+}
diff --git a/sys-fs/fuse-common/metadata.xml b/sys-fs/fuse-common/metadata.xml
new file mode 100644
index 000000000000..b8fe5aef6d9a
--- /dev/null
+++ b/sys-fs/fuse-common/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">libfuse/libfuse</remote-id>
+ </upstream>
+</pkgmetadata>