summaryrefslogtreecommitdiff
path: root/sys-fs/f2fs-tools/f2fs-tools-1.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/f2fs-tools/f2fs-tools-1.6.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/f2fs-tools/f2fs-tools-1.6.1.ebuild')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.6.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.6.1.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.6.1.ebuild
new file mode 100644
index 000000000000..0b088d41d9a5
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib eutils
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/jaegeuk/f2fs-tools.git;a=summary"
+SRC_URI="https://dev.gentoo.org/~blueness/f2fs-tools/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="amd64 arm ~mips ppc ppc64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sysmacros.patch #580338
+}
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf --prefix=/ --includedir=/usr/include
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/$(get_libdir)/libf2fs.{,l}a
+ rm -f "${ED}"/$(get_libdir)/libf2fs_format.{,l}a
+}