summaryrefslogtreecommitdiff
path: root/sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
commit265dbe5dbc14c199299496c6db8fce3f76647015 (patch)
treeab18b5617d138f6684566b619405090989d55a2c /sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild
parent586819755b4dbfdffdc8a725ab7c0f86095b8489 (diff)
gentoo resync : 21.09.2018
Diffstat (limited to 'sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild
new file mode 100644
index 000000000000..700844feff8d
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
+SRC_URI="https://dev.gentoo.org/~zlogene/distfiles/${CATEGORY}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --disable-static \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}