summaryrefslogtreecommitdiff
path: root/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
new file mode 100644
index 000000000000..94561df90d65
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
+SRC_URI="https://dev.gentoo.org/~blueness/f2fs-tools/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/4"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="selinux"
+
+RDEPEND="
+ sys-apps/util-linux
+ selinux? ( sys-libs/libselinux )"
+DEPEND="$RDEPEND"
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --disable-static \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}