summaryrefslogtreecommitdiff
path: root/sys-fs/etcd-fs/etcd-fs-0_p20170517.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/etcd-fs/etcd-fs-0_p20170517.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/etcd-fs/etcd-fs-0_p20170517.ebuild')
-rw-r--r--sys-fs/etcd-fs/etcd-fs-0_p20170517.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-fs/etcd-fs/etcd-fs-0_p20170517.ebuild b/sys-fs/etcd-fs/etcd-fs-0_p20170517.ebuild
new file mode 100644
index 000000000000..20ec3917e7ec
--- /dev/null
+++ b/sys-fs/etcd-fs/etcd-fs-0_p20170517.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-base
+
+KEYWORDS="~amd64"
+EGO_PN="github.com/xetorthio/${PN}"
+DESCRIPTION="Use etcd as a FUSE filesystem"
+HOMEPAGE="https://${EGO_PN}"
+EGIT_COMMIT="1eeace3bc20b15e4347c631a1cf7b45f3852518a"
+SRC_URI="${HOMEPAGE}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+RESTRICT="test"
+DEPEND="
+ dev-db/go-etcd:=
+ dev-libs/go-fuse:="
+RDEPEND=""
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+src_compile() {
+ CGO_CFLAGS=${CFLAGS} GOPATH=${S} \
+ go build \
+ -x -ldflags="-v -linkmode=external -extldflags '${LDFLAGS}'" \
+ etcdfs.go || die
+}
+
+src_install() {
+ dobin etcdfs
+ dodoc README.md
+}