summaryrefslogtreecommitdiff
path: root/sys-fs/duperemove/duperemove-0.14.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
commit59c2499e0c9720169c9d5a02168c51c807a21467 (patch)
tree48c68a8a7e0094b2edaace12850e6c059bc3636b /sys-fs/duperemove/duperemove-0.14.1-r1.ebuild
parenta25cc082a26782e5d39ded4559c91ff11bc3c299 (diff)
gentoo auto-resync : 14:05:2024 - 00:01:24
Diffstat (limited to 'sys-fs/duperemove/duperemove-0.14.1-r1.ebuild')
-rw-r--r--sys-fs/duperemove/duperemove-0.14.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-fs/duperemove/duperemove-0.14.1-r1.ebuild b/sys-fs/duperemove/duperemove-0.14.1-r1.ebuild
new file mode 100644
index 000000000000..30aacbdaf841
--- /dev/null
+++ b/sys-fs/duperemove/duperemove-0.14.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Btrfs and xfs deduplication utility"
+HOMEPAGE="https://github.com/markfasheh/duperemove/"
+# XXX: drop .new on bump after 0.14, added for respin
+SRC_URI="
+ https://github.com/markfasheh/duperemove/archive/v${PV/_/.}.tar.gz
+ -> ${P/_/.}.gh.new.tar.gz
+"
+S=${WORKDIR}/${P/_/.}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 x86"
+
+DEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ # https://github.com/markfasheh/duperemove/issues/344
+ "${FILESDIR}/${P}-32bit.patch"
+)
+
+src_compile() {
+ emake VERSION="${PV}" IS_RELEASE=1 CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}