summaryrefslogtreecommitdiff
path: root/sys-fs/duperemove/duperemove-0.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-16 10:42:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-16 10:42:35 +0100
commit4c16e0a214824f15f09396e359db4f1f5c086fec (patch)
treebfacafd52495915db60285b30438af8bc216d18a /sys-fs/duperemove/duperemove-0.12.ebuild
parent668b36c015ae61191cf7d5007b0afdbdcedab441 (diff)
gentoo auto-resync : 16:07:2023 - 10:42:35
Diffstat (limited to 'sys-fs/duperemove/duperemove-0.12.ebuild')
-rw-r--r--sys-fs/duperemove/duperemove-0.12.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-fs/duperemove/duperemove-0.12.ebuild b/sys-fs/duperemove/duperemove-0.12.ebuild
new file mode 100644
index 000000000000..82e6d1da0fdb
--- /dev/null
+++ b/sys-fs/duperemove/duperemove-0.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Btrfs and xfs deduplication utility"
+HOMEPAGE="https://github.com/markfasheh/duperemove/"
+SRC_URI="
+ https://github.com/markfasheh/duperemove/archive/v${PV/_/.}.tar.gz
+ -> ${P/_/.}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P/_/.}
+
+src_compile() {
+ emake VERSION="${PV}" IS_RELEASE=1 CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}