summaryrefslogtreecommitdiff
path: root/sys-fs/dislocker/dislocker-0.7.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sys-fs/dislocker/dislocker-0.7.1-r3.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sys-fs/dislocker/dislocker-0.7.1-r3.ebuild')
-rw-r--r--sys-fs/dislocker/dislocker-0.7.1-r3.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/sys-fs/dislocker/dislocker-0.7.1-r3.ebuild b/sys-fs/dislocker/dislocker-0.7.1-r3.ebuild
index 73f3b33aa545..90375bf7590b 100644
--- a/sys-fs/dislocker/dislocker-0.7.1-r3.ebuild
+++ b/sys-fs/dislocker/dislocker-0.7.1-r3.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+CMAKE_REMOVE_MODULES_LIST="${CMAKE_REMOVE_MODULES_LIST} FindRuby"
inherit cmake flag-o-matic
-DESCRIPTION="Dislocker is used to read BitLocker encrypted partitions."
+DESCRIPTION="Read BitLocker encrypted partitions"
HOMEPAGE="https://github.com/Aorimn/dislocker"
if [[ ${PV} == *9999* ]]; then
@@ -28,8 +29,6 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-CMAKE_REMOVE_MODULES_LIST="${CMAKE_REMOVE_MODULES_LIST} FindRuby"
-
src_prepare() {
if use ruby && [[ ${PV} == "0.7.1" ]]; then
PATCHES=( "${DISTDIR}/${P}-fix-find-ruby.patch" )
@@ -37,17 +36,17 @@ src_prepare() {
cmake_src_prepare
# We either need to change Werror to Wno-error or remove the multiple declarations of FORTIFY_SOURCE
-# sed 's:Werror:Wno-error:g' -i "${S}/src/CMakeLists.txt" || die
- sed 's:-D_FORTIFY_SOURCE=2::g' -i "${S}/src/CMakeLists.txt" || die
+# sed 's:Werror:Wno-error:g' -i "src/CMakeLists.txt" || die
+ sed 's:-D_FORTIFY_SOURCE=2::g' -i "src/CMakeLists.txt" || die
-# sed 's:\.\./man:'../../${P}/man':g' -i "${S}/src/CMakeLists.txt" || die
+# sed 's:\.\./man:'../../${P}/man':g' -i "src/CMakeLists.txt" || die
# Do not process compressed versions of the manuals
- sed -r 's:( create_symlink \$\{BIN_FUSE\}\.1)\.gz (.+\.1)\.gz\\:\1 \2\\:' -i "${S}/src/CMakeLists.txt" || die
- sed -r 's:^(.+\.1\.gz):#\1:' -i "${S}/src/CMakeLists.txt" || die
+ sed -r 's:( create_symlink \$\{BIN_FUSE\}\.1)\.gz (.+\.1)\.gz\\:\1 \2\\:' -i "src/CMakeLists.txt" || die
+ sed -r 's:^(.+\.1\.gz):#\1:' -i "src/CMakeLists.txt" || die
}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
$(cmake_use_find_package ruby Ruby)
)
cmake_src_configure
@@ -57,6 +56,6 @@ src_install() {
if ! use ruby; then
rm "${S}/man/linux/${PN}-find.1" || die
fi
- find "${S}/man/linux" -name '*.1' -exec doman '{}' +
+ find "${S}/man/linux" -name '*.1' -exec doman '{}' + || die
cmake_src_install
}